aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-17 19:15:02 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-17 19:15:02 +0100
commita720e9fc5917b324514d2cda92957df7f91badc3 (patch)
tree0a011cd946c3a35efd3b07fdadb847d195fb33f7
parentdev-python/hypercorn: add py3.9 (diff)
downloadguru-a720e9fc5917b324514d2cda92957df7f91badc3.tar.gz
guru-a720e9fc5917b324514d2cda92957df7f91badc3.tar.bz2
guru-a720e9fc5917b324514d2cda92957df7f91badc3.zip
dev-python/stdio-mgr: add py3.8 and 3.9
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
index 5cf5ce834..7218e21bc 100644
--- a/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
+++ b/dev-python/stdio-mgr/stdio-mgr-1.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -23,3 +23,8 @@ distutils_enable_tests pytest
#distutils_enable_sphinx doc \
# dev-python/sphinxcontrib-programoutput \
# dev-python/sphinx_rtd_theme
+
+python_test() {
+ # skip the doctests
+ pytest -vv tests || die "Tests failed with ${EPYTHON}"
+}