aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-11-04 23:36:50 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-11-05 09:29:59 +0100
commita7eb360a5f8d9cdbe2a550656054671c8ecba28b (patch)
treef022755c5859b766f6974d567ca38acf9b72b914
parentmedia-libs/libjxl: install jxlinfo in live ebuild (diff)
downloadguru-a7eb360a.tar.gz
guru-a7eb360a.tar.bz2
guru-a7eb360a.zip
dev-python/yaql: NEW version
Closes: https://bugs.gentoo.org/800566 Closes: https://bugs.gentoo.org/800569 Closes: https://bugs.gentoo.org/815571 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/yaql/Manifest2
-rw-r--r--dev-python/yaql/yaql-1.1.3.ebuild24
-rw-r--r--dev-python/yaql/yaql-2.0.0.ebuild41
3 files changed, 42 insertions, 25 deletions
diff --git a/dev-python/yaql/Manifest b/dev-python/yaql/Manifest
index 3bcb8fe64..8fa23e3de 100644
--- a/dev-python/yaql/Manifest
+++ b/dev-python/yaql/Manifest
@@ -1 +1 @@
-DIST yaql-1.1.3.tar.gz 111546 BLAKE2B 2bb2567532cf22a200074baa2e85e0fe90e402dde66e2cbad5f750c95f4e76ee94a068d0be9f741fa932ba4f505f97a2bacf1ad367dea308ce0f69a4d94c9033 SHA512 e85712f65dc932126c75cc84403d14639f76098f4bd22ff2106a68afb6685794e1797154bbf1343e1f82a8b4a13e351d2d0dec1f235e31eecd96f6394116cd4b
+DIST yaql-2.0.0.tar.gz 126174 BLAKE2B 0709c77c30085a2c6ef2ecb643330aef4dd74401b2de358966e146baa57a70a7a09067f55edd07cb1a1fe20a4b4613920ffd0f5b46123343be0ea701cd80b1a5 SHA512 9e28552b833b3dcf5ba40e46f6cffe70e0ecca831c25ac013ab2ec4b85c370103a870efe2efdcf2626cc09ff8b6fc9441451bd9963effbd0b8b903f5e06628c5
diff --git a/dev-python/yaql/yaql-1.1.3.ebuild b/dev-python/yaql/yaql-1.1.3.ebuild
deleted file mode 100644
index 3d54615fd..000000000
--- a/dev-python/yaql/yaql-1.1.3.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_8 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="YAQL: Yet Another Query Language"
-HOMEPAGE="https://github.com/openstack/yaql"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/yaql/yaql-2.0.0.ebuild b/dev-python/yaql/yaql-2.0.0.ebuild
new file mode 100644
index 000000000..4f304285c
--- /dev/null
+++ b/dev-python/yaql/yaql-2.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="YAQL: Yet Another Query Language"
+HOMEPAGE="
+ https://github.com/openstack/yaql
+ https://pypi.org/project/yaql
+ https://launchpad.net/yaql
+ https://opendev.org/openstack/yaql
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ >=dev-python/hacking-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+
+ )
+"
+
+distutils_enable_tests pytest