aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-05-31 13:36:45 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-05-31 13:36:45 +0200
commita81a4f6e6c3e0afade25a46441e7251758558024 (patch)
treeea08dadc94a56f82cc8feff826c62c158e52a284
parentdev-embedded/rauc: Add missing dependency (diff)
downloadguru-a81a4f6e.tar.gz
guru-a81a4f6e.tar.bz2
guru-a81a4f6e.zip
games-util/legendary: Version bump 0.0.17.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--games-util/legendary/Manifest1
-rw-r--r--games-util/legendary/legendary-0.0.17.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/games-util/legendary/Manifest b/games-util/legendary/Manifest
index e0fd310e5..2bbe9d5a0 100644
--- a/games-util/legendary/Manifest
+++ b/games-util/legendary/Manifest
@@ -1,2 +1,3 @@
DIST legendary-0.0.14.tar.gz 65153 BLAKE2B 94c3e05c36a2d472c49030bfabe2d4469880e8ee07fedc28472f69e825428f448d0b7f4c701958c34f91c00d1482bc73739ab6ce92aad6e1ae6cbde50e76541e SHA512 455b0f1d0dc61d21e3927c324afe9dc6caf36fc003d5934a83dc06b7970f8b8ff5fa884d875a0511a1e8bf86199eda4027daa94428c52bf63dfff791ceda2ddb
DIST legendary-0.0.15.tar.gz 71630 BLAKE2B 2cc7292c73cbc490c31796766783a60ba55be78415eac6d2d06e1df3dc108901dba99373af0504319f2467b110dded1b5bc0d898ef62977d0716369c148deaeb SHA512 60908b52b2d706e538b67a63f031e4c55ab1f9d88c84154994477eb79806b406d0ef4bae9ba431c5f854e1058f72c82d3cd3faeccef28a64fb74acf365ad8205
+DIST legendary-0.0.17.tar.gz 72469 BLAKE2B e7f068cda589c1188068be0e9b18bfc5346d92a2a91a804faadcd856a192c2a49e00f268621573915f4502552a686702be5bdbdb23f9b062f5f4c2ab618d5b74 SHA512 4dbdb5605edbf43c1a16161436007d4d050dd7dcbfae35ace0ec03460db08f7bbe099d184af0aba0c6d8d26a592d9b3f7ea436c99c61fb9c2386211fdee02c3f
diff --git a/games-util/legendary/legendary-0.0.17.ebuild b/games-util/legendary/legendary-0.0.17.ebuild
new file mode 100644
index 000000000..7310e06d7
--- /dev/null
+++ b/games-util/legendary/legendary-0.0.17.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="A free and open-source replacement for the Epic Games Launcher"
+HOMEPAGE="https://github.com/derrod/legendary"
+SRC_URI="https://github.com/derrod/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"