aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrian gloyer <brian.gloyer@gmail.com>2022-01-07 22:45:06 -0800
committerbrian gloyer <brian.gloyer@gmail.com>2022-01-07 22:45:06 -0800
commita93bdbcec8a28899e3928d4ecf831200a61bc46a (patch)
tree8df022535d729960fb45e7e33a3618060b9e7084
parentdev-libs/olm: Version bump 3.2.9 (diff)
downloadguru-a93bdbce.tar.gz
guru-a93bdbce.tar.bz2
guru-a93bdbce.zip
games-action/netrek-cow: patch configure.ac
Closes: https://bugs.gentoo.org/816534 Signed-off-by: brian gloyer <brian.gloyer@gmail.com>
-rw-r--r--games-action/netrek-cow/autoupdate.patch103
-rw-r--r--games-action/netrek-cow/netrek-cow/Manifest4
-rw-r--r--games-action/netrek-cow/netrek-cow/files/netrek-cow-3.3.2-autoupdate.patch103
-rw-r--r--games-action/netrek-cow/netrek-cow/metadata.xml16
-rw-r--r--games-action/netrek-cow/netrek-cow/netrek-cow-3.3.2.ebuild45
5 files changed, 271 insertions, 0 deletions
diff --git a/games-action/netrek-cow/autoupdate.patch b/games-action/netrek-cow/autoupdate.patch
new file mode 100644
index 000000000..e9ededa2f
--- /dev/null
+++ b/games-action/netrek-cow/autoupdate.patch
@@ -0,0 +1,103 @@
+diff --git a/configure.ac b/configure.ac
+index ce956ee..5bb0866 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,9 +1,10 @@
+ dnl This file is an input file used by the GNU "autoconf" program to
+ dnl generate the file "configure", which is run during Netrek installation
+ dnl to configure the system for the local environment.
+-AC_INIT(name.c)
+-AC_CANONICAL_SYSTEM
+-AC_CONFIG_HEADER(config.h)
++AC_INIT
++AC_CONFIG_SRCDIR([name.c])
++AC_CANONICAL_TARGET
++AC_CONFIG_HEADERS([config.h])
+
+ AC_PROG_INSTALL
+
+@@ -11,7 +12,7 @@ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_LN_S
+
+-AC_AIX
++AC_USE_SYSTEM_EXTENSIONS
+
+ AC_C_INLINE
+
+@@ -26,18 +27,24 @@ AC_C_INLINE
+ #--------------------------------------------------------------------
+
+ AC_MSG_CHECKING(if fd_set requires sys/select.h)
+-AC_TRY_COMPILE( [#include <sys/types.h>], [fd_set readMask, writeMask;],
+- AC_MSG_RESULT(no) ,
+- AC_EGREP_HEADER(fd_set, sys/select.h,
++AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>]], [[fd_set readMask, writeMask;]])],[AC_MSG_RESULT(no) ],[AC_EGREP_HEADER(fd_set, sys/select.h,
+ AC_DEFINE(NEED_SYS_SELECT_H) AC_MSG_RESULT(yes),
+- AC_DEFINE(NO_FD_SET) AC_MSG_RESULT(fd_set missing)))
++ AC_DEFINE(NO_FD_SET) AC_MSG_RESULT(fd_set missing))])
+
+ #--------------------------------------------------------------------
+ # Check for various typedefs and provide substitutes if
+ # they don't exist.
+ #--------------------------------------------------------------------
+
+-AC_HEADER_STDC
++m4_warn([obsolete],
++[The preprocessor macro `STDC_HEADERS' is obsolete.
++ Except in unusual embedded environments, you can safely include all
++ ISO C90 headers unconditionally.])dnl
++# Autoupdate added the next two lines to ensure that your configure
++# script's behavior did not change. They are probably safe to remove.
++AC_CHECK_INCLUDES_DEFAULT
++AC_PROG_EGREP
++
+ AC_CHECK_HEADERS(unistd.h memory.h math.h stdlib.h)
+ AC_CHECK_HEADERS(sys/timeb.h sys/ptyio.h sys/fcntl.h fcntl.h)
+ AC_CHECK_HEADERS(ctype.h machine/endian.h sys/resource.h)
+@@ -46,7 +53,7 @@ AC_CHECK_HEADERS(sys/wait.h netinet/in.h netinet/tcp.h sys/filio.h)
+ AC_TYPE_PID_T
+ AC_TYPE_UID_T
+ AC_TYPE_SIZE_T
+-AC_FUNC_VFORK
++AC_FUNC_FORK
+ AC_STRUCT_TM
+
+ AC_MSG_CHECKING(for itimer in time.h)
+@@ -80,7 +87,7 @@ if test -z "$NOX11" ; then
+ if test -z "$x_libraries" ; then
+ echo checking for X11 header files
+ XINCLUDES=""
+-AC_TRY_CPP([#include <X11/Intrinsic.h>], , XINCLUDES="nope")
++AC_PREPROC_IFELSE([AC_LANG_SOURCE([[#include <X11/Intrinsic.h>]])],[],[XINCLUDES="nope"])
+ if test "$XINCLUDES" = nope; then
+ dirs="/usr/unsupported/include /usr/local/include /usr/X386/include \
+ /usr/include/X11R4 /usr/X11R5/include /usr/include/X11R5 \
+@@ -165,7 +172,19 @@ AC_CHECK_LIB(sun, main, [LIBS="$LIBS -lsun"])
+ # Check for type of signals
+ #--------------------------------------------------------------------
+
+-AC_TYPE_SIGNAL
++m4_warn([obsolete],
++[your code may safely assume C89 semantics that RETSIGTYPE is void.
++Remove this warning and the `AC_CACHE_CHECK' when you adjust the code.])dnl
++AC_CACHE_CHECK([return type of signal handlers],[ac_cv_type_signal],[AC_COMPILE_IFELSE(
++[AC_LANG_PROGRAM([#include <sys/types.h>
++#include <signal.h>
++],
++ [return *(signal (0, 0)) (0) == 1;])],
++ [ac_cv_type_signal=int],
++ [ac_cv_type_signal=void])])
++AC_DEFINE_UNQUOTED([RETSIGTYPE],[$ac_cv_type_signal],[Define as the return type of signal handlers
++ (`int' or `void').])
++
+ AC_CHECK_FUNCS(usleep random setstate strftime ftime)
+ AC_CHECK_LIB(m, main, [LIBS="$LIBS -lm"])
+ AC_CHECK_FUNCS(nint)
+@@ -201,4 +220,5 @@ fi
+ #--------------------------------------------------------------------
+ # Emit output
+ #--------------------------------------------------------------------
+-AC_OUTPUT(system.mk)
++AC_CONFIG_FILES([system.mk])
++AC_OUTPUT
diff --git a/games-action/netrek-cow/netrek-cow/Manifest b/games-action/netrek-cow/netrek-cow/Manifest
new file mode 100644
index 000000000..564830077
--- /dev/null
+++ b/games-action/netrek-cow/netrek-cow/Manifest
@@ -0,0 +1,4 @@
+AUX netrek-cow-3.3.2-autoupdate.patch 3820 BLAKE2B 41e9de377f196e64d8764cacc4e609b11edcfd73ae5f8b3151e7cc9d63603ce4ba9d2a23de215303b49d1914f62688c0bb5f42330595573a3872e3cae435d659 SHA512 b270a4f51720b7bc7ff6a85c076d92bb31fd492528ed12b85fa390b72b9e43d1b14824bbdcea40710c6b409b4f036625d914b9024aab10accb536c6cb4db921c
+DIST netrek-cow-3.3.2.tar.gz 2630673 BLAKE2B 1a54b58d112f0893275b57967573ce308e69b99e42a660670f3a5fc7f15f2dc110f2008e496282a58da181252a196feb8218a87f52db16444f1f50cef2a6809f SHA512 9a0ab78ed86d174f52d35d30a409efd985bd2d39062a993c3790f36ade1fa0a9b95b9d914f5c1fa57497f281e88ece0f6bc86abc962bd87ff44f68c1416f07f0
+EBUILD netrek-cow-3.3.2.ebuild 767 BLAKE2B 560e534e13708003e905d58d04944b1dc37e956baeae0f2c1dbcff28ce307570e2e10db781c83a2f073bdb77db4bd265677ae371b29443075aa112967e5088a9 SHA512 acc5cded53ba6a7df74c42afcf90a1e02b6a1a85b537e1948305c714f9a0e03e2bb546b665ae9a62c0123c0b1ccc959c46c2aea8c9bd59f78d969e073c13b2c4
+MISC metadata.xml 549 BLAKE2B 9f82dafe4f3010a8794c656f0b2d50c2adb18fd0a570c37cdd03dd21a910db089f2ac61ec5abe592fa5c7a47fe00753ea6581b0313665eee75cebeee36000ea8 SHA512 a7723c9a9d4e0ffa94dab929633d795ed3b077e18af3f277a2c0012eb91deb15cb1a9b8f1ac8e927f663fdab23eae26762c7987faa24e991bc49ffe5129ef614
diff --git a/games-action/netrek-cow/netrek-cow/files/netrek-cow-3.3.2-autoupdate.patch b/games-action/netrek-cow/netrek-cow/files/netrek-cow-3.3.2-autoupdate.patch
new file mode 100644
index 000000000..e9ededa2f
--- /dev/null
+++ b/games-action/netrek-cow/netrek-cow/files/netrek-cow-3.3.2-autoupdate.patch
@@ -0,0 +1,103 @@
+diff --git a/configure.ac b/configure.ac
+index ce956ee..5bb0866 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,9 +1,10 @@
+ dnl This file is an input file used by the GNU "autoconf" program to
+ dnl generate the file "configure", which is run during Netrek installation
+ dnl to configure the system for the local environment.
+-AC_INIT(name.c)
+-AC_CANONICAL_SYSTEM
+-AC_CONFIG_HEADER(config.h)
++AC_INIT
++AC_CONFIG_SRCDIR([name.c])
++AC_CANONICAL_TARGET
++AC_CONFIG_HEADERS([config.h])
+
+ AC_PROG_INSTALL
+
+@@ -11,7 +12,7 @@ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_LN_S
+
+-AC_AIX
++AC_USE_SYSTEM_EXTENSIONS
+
+ AC_C_INLINE
+
+@@ -26,18 +27,24 @@ AC_C_INLINE
+ #--------------------------------------------------------------------
+
+ AC_MSG_CHECKING(if fd_set requires sys/select.h)
+-AC_TRY_COMPILE( [#include <sys/types.h>], [fd_set readMask, writeMask;],
+- AC_MSG_RESULT(no) ,
+- AC_EGREP_HEADER(fd_set, sys/select.h,
++AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>]], [[fd_set readMask, writeMask;]])],[AC_MSG_RESULT(no) ],[AC_EGREP_HEADER(fd_set, sys/select.h,
+ AC_DEFINE(NEED_SYS_SELECT_H) AC_MSG_RESULT(yes),
+- AC_DEFINE(NO_FD_SET) AC_MSG_RESULT(fd_set missing)))
++ AC_DEFINE(NO_FD_SET) AC_MSG_RESULT(fd_set missing))])
+
+ #--------------------------------------------------------------------
+ # Check for various typedefs and provide substitutes if
+ # they don't exist.
+ #--------------------------------------------------------------------
+
+-AC_HEADER_STDC
++m4_warn([obsolete],
++[The preprocessor macro `STDC_HEADERS' is obsolete.
++ Except in unusual embedded environments, you can safely include all
++ ISO C90 headers unconditionally.])dnl
++# Autoupdate added the next two lines to ensure that your configure
++# script's behavior did not change. They are probably safe to remove.
++AC_CHECK_INCLUDES_DEFAULT
++AC_PROG_EGREP
++
+ AC_CHECK_HEADERS(unistd.h memory.h math.h stdlib.h)
+ AC_CHECK_HEADERS(sys/timeb.h sys/ptyio.h sys/fcntl.h fcntl.h)
+ AC_CHECK_HEADERS(ctype.h machine/endian.h sys/resource.h)
+@@ -46,7 +53,7 @@ AC_CHECK_HEADERS(sys/wait.h netinet/in.h netinet/tcp.h sys/filio.h)
+ AC_TYPE_PID_T
+ AC_TYPE_UID_T
+ AC_TYPE_SIZE_T
+-AC_FUNC_VFORK
++AC_FUNC_FORK
+ AC_STRUCT_TM
+
+ AC_MSG_CHECKING(for itimer in time.h)
+@@ -80,7 +87,7 @@ if test -z "$NOX11" ; then
+ if test -z "$x_libraries" ; then
+ echo checking for X11 header files
+ XINCLUDES=""
+-AC_TRY_CPP([#include <X11/Intrinsic.h>], , XINCLUDES="nope")
++AC_PREPROC_IFELSE([AC_LANG_SOURCE([[#include <X11/Intrinsic.h>]])],[],[XINCLUDES="nope"])
+ if test "$XINCLUDES" = nope; then
+ dirs="/usr/unsupported/include /usr/local/include /usr/X386/include \
+ /usr/include/X11R4 /usr/X11R5/include /usr/include/X11R5 \
+@@ -165,7 +172,19 @@ AC_CHECK_LIB(sun, main, [LIBS="$LIBS -lsun"])
+ # Check for type of signals
+ #--------------------------------------------------------------------
+
+-AC_TYPE_SIGNAL
++m4_warn([obsolete],
++[your code may safely assume C89 semantics that RETSIGTYPE is void.
++Remove this warning and the `AC_CACHE_CHECK' when you adjust the code.])dnl
++AC_CACHE_CHECK([return type of signal handlers],[ac_cv_type_signal],[AC_COMPILE_IFELSE(
++[AC_LANG_PROGRAM([#include <sys/types.h>
++#include <signal.h>
++],
++ [return *(signal (0, 0)) (0) == 1;])],
++ [ac_cv_type_signal=int],
++ [ac_cv_type_signal=void])])
++AC_DEFINE_UNQUOTED([RETSIGTYPE],[$ac_cv_type_signal],[Define as the return type of signal handlers
++ (`int' or `void').])
++
+ AC_CHECK_FUNCS(usleep random setstate strftime ftime)
+ AC_CHECK_LIB(m, main, [LIBS="$LIBS -lm"])
+ AC_CHECK_FUNCS(nint)
+@@ -201,4 +220,5 @@ fi
+ #--------------------------------------------------------------------
+ # Emit output
+ #--------------------------------------------------------------------
+-AC_OUTPUT(system.mk)
++AC_CONFIG_FILES([system.mk])
++AC_OUTPUT
diff --git a/games-action/netrek-cow/netrek-cow/metadata.xml b/games-action/netrek-cow/netrek-cow/metadata.xml
new file mode 100644
index 000000000..bf36b0504
--- /dev/null
+++ b/games-action/netrek-cow/netrek-cow/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>brian.gloyer@gmail.com</email>
+ <name>brian gloyer</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>brian.gloyer@gmail.com</email>
+ <name>brian gloyer</name>
+ </maintainer>
+ <bugs-to>https://github.com/quozl/netrek-client-cow/issues/</bugs-to>
+ <remote-id type="github">quozl/netrek-client-cow</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/netrek-cow/netrek-cow/netrek-cow-3.3.2.ebuild b/games-action/netrek-cow/netrek-cow/netrek-cow-3.3.2.ebuild
new file mode 100644
index 000000000..a552ae655
--- /dev/null
+++ b/games-action/netrek-cow/netrek-cow/netrek-cow-3.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="cow client for netrek"
+HOMEPAGE="https://netrek.org"
+SRC_URI="https://github.com/quozl/netrek-client-cow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/netrek-client-cow-${PV}"
+
+# upstream has a file named check that is unrelated to tests
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/imlib2
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ x11-libs/libXmu
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+ ./autogen.sh
+ eautoreconf
+}
+
+src_install() {
+ dobin netrek-client-cow
+}
+
+PATCHES=(
+ "${FILESDIR}/${P}-autoupdate.patch"
+)