aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaud CANALE <thican@thican.net>2022-08-07 20:35:43 +0200
committerThibaud CANALE <thican@thican.net>2022-08-07 20:35:43 +0200
commitaa2a03e20ed8ca53a75840fc390771bc9422f238 (patch)
tree17f5efb1fffa14702e41f869feb42f681e7dd961
parentapp-emulation/proton-ge-custom-bin: add 7.29 (diff)
downloadguru-aa2a03e2.tar.gz
guru-aa2a03e2.tar.bz2
guru-aa2a03e2.zip
media-gfx/heatshrink: new package, add 0.4.1
Signed-off-by: Thibaud CANALE <thican@thican.net>
-rw-r--r--media-gfx/heatshrink/Manifest1
-rw-r--r--media-gfx/heatshrink/files/Makefile.patch23
-rw-r--r--media-gfx/heatshrink/heatshrink-0.4.1.ebuild29
3 files changed, 53 insertions, 0 deletions
diff --git a/media-gfx/heatshrink/Manifest b/media-gfx/heatshrink/Manifest
new file mode 100644
index 000000000..b23793093
--- /dev/null
+++ b/media-gfx/heatshrink/Manifest
@@ -0,0 +1 @@
+DIST heatshrink-0.4.1.tar.gz 36945 BLAKE2B 526e3f88ddaec8116e5eef1a73a4450454ca808545dfe4a36069be8a0d771ca92c850c51f9b3c3e73f244454ba17d03da8fb0be4849728300c7eb8181e39651e SHA512 bb9610b963da0762b1ac21d0907f3801b525431abff495b66cadc244a2b2b334441de2b14442b722bfeb56cb4459fe4021eae0d0454f9e26a80e6efa11f079d2
diff --git a/media-gfx/heatshrink/files/Makefile.patch b/media-gfx/heatshrink/files/Makefile.patch
new file mode 100644
index 000000000..a858ec0c1
--- /dev/null
+++ b/media-gfx/heatshrink/files/Makefile.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index d0c4dbe6..5cd8977a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,8 @@ WARN += -Wmissing-declarations
+ #THEFT_INC= -I${THEFT_PATH}/include/
+ #LDFLAGS += -L${THEFT_PATH}/lib -ltheft
+
+-CFLAGS += -std=c99 -g ${WARN} ${THEFT_INC} ${OPTIMIZE}
++MY_CFLAGS := -std=c99 ${WARN} ${THEFT_INC} ${OPTIMIZE} ${CFLAGS}
++CFLAGS := ${MY_CFLAGS}
+
+ all: heatshrink test_runners libraries
+
+@@ -66,8 +67,6 @@ RM ?= rm
+
+ install: libraries heatshrink
+ ${INSTALL} -c heatshrink ${PREFIX}/bin/
+- ${INSTALL} -c libheatshrink_static.a ${PREFIX}/lib/
+- ${INSTALL} -c libheatshrink_dynamic.a ${PREFIX}/lib/
+ ${INSTALL} -c heatshrink_common.h ${PREFIX}/include/
+ ${INSTALL} -c heatshrink_config.h ${PREFIX}/include/
+ ${INSTALL} -c heatshrink_encoder.h ${PREFIX}/include/
diff --git a/media-gfx/heatshrink/heatshrink-0.4.1.ebuild b/media-gfx/heatshrink/heatshrink-0.4.1.ebuild
new file mode 100644
index 000000000..9c7bffdf4
--- /dev/null
+++ b/media-gfx/heatshrink/heatshrink-0.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="data compression library for embedded/real-time systems"
+HOMEPAGE="https://github.com/atomicobject/heatshrink"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atomicobject/${PN}.git"
+else
+ inherit verify-sig
+ SRC_URI="https://github.com/atomicobject/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/Makefile.patch"
+)
+
+src_install() {
+ local MY_ED="${ED}/usr"
+ mkdir "${MY_ED%/}"{,/bin,/include} || die
+ emake PREFIX="${MY_ED%/}/" install
+}