aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-09-17 11:39:18 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-09-17 11:53:17 +0200
commitaadff049ecc879d2738c9332fb47bb77a2d9b863 (patch)
tree5fa096609be6c1984b6b721f1da2b20255531d65
parentdev-libs/olm: Fix bugs-to address. (diff)
downloadguru-aadff049.tar.gz
guru-aadff049.tar.bz2
guru-aadff049.zip
dev-libs/olm: Version bump 3.2.6.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-libs/olm/Manifest1
-rw-r--r--dev-libs/olm/olm-3.2.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/olm/Manifest b/dev-libs/olm/Manifest
index 5bf808fec..295bde68e 100644
--- a/dev-libs/olm/Manifest
+++ b/dev-libs/olm/Manifest
@@ -1,2 +1,3 @@
DIST olm-3.2.3.tar.bz2 478365 BLAKE2B d8b5069e07958a4fe12a0aeea2ba25a7b7c319c96c980abd78f78881489e68d400594a0076ecf345561364c657eb9faf54819043ca9b51af01633d8e21edf069 SHA512 b01b5bb41d828e15520a1054cd9a479ff5d464552bc379269b9bf12fd54929d2e4cd31a46c0ea07a26ead7410e50caf80d3711912131147794d88d96947ffe59
DIST olm-3.2.4.tar.bz2 479336 BLAKE2B 9de6b869c94a7f47b269b55526408ce6930ac5354495608038888f13efe72a6fab498c85c6ffe073a1f76391cbe4a83cfc6c65382d593bc487dafe64894ca0ed SHA512 94f661a2c9fe22f7dfefc89e488be37da2fe19dedd3ba296e09c55e63886ed82b71a30d84ecbdfa5dee820b1b6a918daefab248536c137459b8f244dc514920b
+DIST olm-3.2.6.tar.bz2 485416 BLAKE2B 414e636a1bd32ff7698f3db7748a77aaa2449d260c79f3dcb64db6c509e4f972e4098e439838eb876bc7b738d25a5c704fed94edc9ca41f2c036c3d1438934f0 SHA512 e22af4e7791962978ea4c39b9bebf807a864ca52b329f032e5e398864cd142c1f166aadbce74cb85f776cb0b8352754151f64c60dac2ce1858def73d684fd44a
diff --git a/dev-libs/olm/olm-3.2.6.ebuild b/dev-libs/olm/olm-3.2.6.ebuild
new file mode 100644
index 000000000..aa65115cc
--- /dev/null
+++ b/dev-libs/olm/olm-3.2.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implementation of the olm and megolm cryptographic ratchets"
+HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm"
+SRC_URI="https://gitlab.matrix.org/matrix-org/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DOLM_TESTS="$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
+}
+
+src_install() {
+ use doc && DOCS=( README.md docs/{{,meg}olm,signing}.md )
+
+ cmake_src_install
+}