aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-30 20:17:19 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-04-30 21:57:19 +0200
commitabae8dd6d869f6709c3513e7f796a31a1d2a7e5a (patch)
tree0028d6f6d3b179542eaea03dbcb3846ded84682a
parentwww-client/woob: fix StaticSrcUri (diff)
downloadguru-abae8dd6d869f6709c3513e7f796a31a1d2a7e5a.tar.gz
guru-abae8dd6d869f6709c3513e7f796a31a1d2a7e5a.tar.bz2
guru-abae8dd6d869f6709c3513e7f796a31a1d2a7e5a.zip
media-libs/libbpg: Set CC and CXX for CMake.
CMake is called from the Makefile and it can't find the compilers if there are no `cc` and `cxx` symlinks. Inheriting cmake.eclass would require us to run cmake_src_prepare which would interfere with upstream's build system. Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--media-libs/libbpg/libbpg-0.9.8.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-libs/libbpg/libbpg-0.9.8.ebuild b/media-libs/libbpg/libbpg-0.9.8.ebuild
index e1120b791..1d8149d0c 100644
--- a/media-libs/libbpg/libbpg-0.9.8.ebuild
+++ b/media-libs/libbpg/libbpg-0.9.8.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Better Portable Graphics reference implementation"
HOMEPAGE="https://bellard.org/bpg/"
SRC_URI="https://bellard.org/bpg/${P}.tar.gz"
@@ -51,7 +53,9 @@ src_compile() {
$(usex x265 USE_X265=y '') \
$(usex bpgview USE_BPGVIEW=y '') \
$(usex jctvc USE_JCTVC=y '') \
- $(usex emcc USE_EMCC=y '')
+ $(usex emcc USE_EMCC=y '') \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)"
}
src_install() {