aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2022-11-07 19:52:20 +0100
committerAlexey Zapparov <alexey@zapparov.com>2022-11-07 19:52:20 +0100
commitac3fd4653ae89b80ac473735a1bd1b839817f782 (patch)
tree8521585350d3369c077bf9868042ef10e859cf4d
parentgames-util/legendary: add 0.20.31 (diff)
downloadguru-ac3fd465.tar.gz
guru-ac3fd465.tar.bz2
guru-ac3fd465.zip
dev-ruby/ruby-install: add 0.8.5
Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
-rw-r--r--dev-ruby/ruby-install/Manifest1
-rw-r--r--dev-ruby/ruby-install/ruby-install-0.8.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/ruby-install/Manifest b/dev-ruby/ruby-install/Manifest
index 49a69c0e8..c0e5fbb21 100644
--- a/dev-ruby/ruby-install/Manifest
+++ b/dev-ruby/ruby-install/Manifest
@@ -1,2 +1,3 @@
DIST ruby-install-0.8.3.tar.gz 32381 BLAKE2B fd2c15333e571881d9a6be67c2b968f81bd8b2d2025972dd502df35b4ce1b2a5dbfbac29327d2dfa83b779f923342c23c30423455c202a0978581ab71291ce22 SHA512 1fdd44b709a7d2eaae4b1ebf7a08381c565d7656d52cf69b98b0e00d383b39c7776848f7acd5f5f79f1a9ad935907e230c256b7cdf46714fddd9a8cfac418c9a
DIST ruby-install-0.8.4.tar.gz 32652 BLAKE2B e863645c66cc631d17a3e5c061220fd59d0b0458613d31e8db4d35fbb0beae53ccf627620b9adb08bb0db82d51bd9a54a7eb96079fc3e6604c32d9b7dc219f3d SHA512 9d7157ab73689a7024efae104f6fd244c019c56d5e27573151818dd72f07855f9785b2ddba9c83a413ddcd92a565893373ca545c486c59b4fa408f349d4c7f48
+DIST ruby-install-0.8.5.tar.gz 32904 BLAKE2B 6128d489c53c02b53b96f243a7c5fd3de2a360eac8ed7873c89cfafb229e611f77f3275e66bb1aef0ccad772029f7727c0e4a62c6dc74ec1780c7badd219cc52 SHA512 4f5546652e741eb4b1b72780a73e0b41b8bd212dd979e31124b8a1a96e9bbebdcb7951da20768b992776206a446b489214f2b1261255855760e2e3477118f8d7
diff --git a/dev-ruby/ruby-install/ruby-install-0.8.5.ebuild b/dev-ruby/ruby-install/ruby-install-0.8.5.ebuild
new file mode 100644
index 000000000..706d5e5d2
--- /dev/null
+++ b/dev-ruby/ruby-install/ruby-install-0.8.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Installs Ruby, JRuby, Rubinius, TruffleRuby (native / GraalVM), or mruby."
+HOMEPAGE="https://github.com/postmodern/ruby-install"
+SRC_URI="https://github.com/postmodern/ruby-install/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PROPERTIES="test_network"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=app-shells/bash-3.0:*"
+RDEPEND="${DEPEND}
+ sys-apps/grep
+ || ( >net-misc/wget-1.12 net-misc/curl )
+ dev-libs/openssl
+ app-arch/tar
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-devel/patch
+ || ( >=sys-devel/gcc-4.2 sys-devel/clang )"
+BDEPEND="test? ( dev-util/shunit2 )"
+
+# XXX: `make check` seems to be broken (violates shellcheck tests)
+src_test() {
+ emake test
+}
+
+src_prepare() {
+ default
+
+ sed -i Makefile -e "s/^VERSION=.\+$/VERSION=${PVR}/" \
+ || die "Cannot fix doc location to follow Gentoo/FHS guidelines"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}