aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-01-28 02:39:10 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-01-28 02:39:10 +0100
commitad7502b968674c20e1e183ad2262c2eb6b579163 (patch)
treec825a74f59a3f1fd289cafa3306e2d935eb84df0
parentdev-libs/mtxclient: Version bump 0.4.1. (diff)
downloadguru-ad7502b9.tar.gz
guru-ad7502b9.tar.bz2
guru-ad7502b9.zip
dev-libs/mtxclient: Delete old ebuilds.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-libs/mtxclient/Manifest2
-rw-r--r--dev-libs/mtxclient/mtxclient-0.3.1.ebuild43
-rw-r--r--dev-libs/mtxclient/mtxclient-0.4.0.ebuild42
3 files changed, 0 insertions, 87 deletions
diff --git a/dev-libs/mtxclient/Manifest b/dev-libs/mtxclient/Manifest
index 8917afd97..15aa7e7f4 100644
--- a/dev-libs/mtxclient/Manifest
+++ b/dev-libs/mtxclient/Manifest
@@ -1,3 +1 @@
-DIST mtxclient-0.3.1.tar.gz 511985 BLAKE2B 5271dc755ea10be2bddd0155b9c3288be2f0cb165989fdebcf237795a12041e8f21f7c54b9f7ec86e5fa08c386daad696f77509ae65b2aa2c30c9a292bb1b682 SHA512 ed4991b0a611be80cef42dec5e4b747787dae6aeaf46dc1cc395b06233efc9a5b1b57b1809eb9dacd7893b4de19f43996bb6d4556fc67697013248d79528a567
-DIST mtxclient-0.4.0.tar.gz 571434 BLAKE2B d836d94f9045f0ca5a0aa9b5fe6f3643e3189d4ee31b797472aca10320678308d51e2c9bc37f4234d00e0c201aeefaf8c4c40072b0ad8c7f5b6a9e0c10163a2a SHA512 8c3538147b9277babbac14aaec6652ff638ae9335c01f786dfec78e3edc5c23591da8ce33c4366329050cf644f71a9fac8d337a2a9fbf7ea2883be05f6ac1a1e
DIST mtxclient-0.4.1.tar.gz 572552 BLAKE2B 4d0facaffb0ce1fadc1011b7d557774bcd9ffcef7349894255b9522bcc4e9228739ad8da5a60b0addf6835cf5de3613bebc19842b6922ab9cf94f88c944d0091 SHA512 246c84bc8bc7dd6fd688c79601d16e931b5aaf5fe967d6ea226f1961df2b74ad70d4e790b7400051e007506f58ecd6594ccead31bd3c6308aa2c6727b122c203
diff --git a/dev-libs/mtxclient/mtxclient-0.3.1.ebuild b/dev-libs/mtxclient/mtxclient-0.3.1.ebuild
deleted file mode 100644
index fcdc9114a..000000000
--- a/dev-libs/mtxclient/mtxclient-0.3.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Client API library for Matrix, built on top of Boost.Asio"
-HOMEPAGE="https://github.com/Nheko-Reborn/mtxclient"
-SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-libs/libsodium
- >=dev-libs/boost-1.70.0
- dev-libs/olm
- dev-libs/openssl
- dev-cpp/nlohmann_json
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/spdlog
- test? ( dev-cpp/gtest )
-"
-
-# remove_failing_tests depends on remove_network_tests.
-PATCHES=(
- "${FILESDIR}/0.3.0_remove_network_tests.patch"
- "${FILESDIR}/0.3.0_remove_failing_tests.patch"
-)
-
-src_configure() {
- local -a mycmakeargs=(
- -DBUILD_LIB_TESTS="$(usex test)"
- -DBUILD_LIB_EXAMPLES=OFF
- )
-
- cmake_src_configure
-}
diff --git a/dev-libs/mtxclient/mtxclient-0.4.0.ebuild b/dev-libs/mtxclient/mtxclient-0.4.0.ebuild
deleted file mode 100644
index 6589f98e0..000000000
--- a/dev-libs/mtxclient/mtxclient-0.4.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Client API library for Matrix, built on top of Boost.Asio"
-HOMEPAGE="https://github.com/Nheko-Reborn/mtxclient"
-SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-libs/boost-1.70.0
- dev-libs/olm
- >=dev-libs/openssl-1.1.0
- dev-cpp/nlohmann_json
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/spdlog
- test? ( dev-cpp/gtest )
-"
-
-# remove_failing_tests depends on remove_network_tests.
-PATCHES=(
- "${FILESDIR}/0.3.0_remove_network_tests.patch"
- "${FILESDIR}/0.3.0_remove_failing_tests.patch"
-)
-
-src_configure() {
- local -a mycmakeargs=(
- -DBUILD_LIB_TESTS="$(usex test)"
- -DBUILD_LIB_EXAMPLES=OFF
- )
-
- cmake_src_configure
-}