aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-04-25 16:39:38 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-04-25 16:39:38 +0300
commitb01f220bb555da848da3cdb75bcf7a1fd2045c2d (patch)
tree14b31ac3b94f1d0011f58976d37f414ca50ec80e
parentkde-apps/kclock: add missing runtime dependency (diff)
downloadguru-b01f220b.tar.gz
guru-b01f220b.tar.bz2
guru-b01f220b.zip
dev-libs/ftl: new package
The Fortran Template Library (FTL) is a general purpose library for Fortran 2003 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--dev-libs/ftl/Manifest1
-rw-r--r--dev-libs/ftl/ftl-1.0_p20210308.ebuild66
-rw-r--r--dev-libs/ftl/metadata.xml19
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/ftl/Manifest b/dev-libs/ftl/Manifest
new file mode 100644
index 0000000000..4afd58e950
--- /dev/null
+++ b/dev-libs/ftl/Manifest
@@ -0,0 +1 @@
+DIST ftl-1.0_p20210308.tar.gz 732263 BLAKE2B 2a369b809f2b0d77ffe002d2e9ffaffabcb4f12565c0bb5bcbcce5899bac030dd127427dd8f89b3595d98441b9b145daf8661ed9c46977ac6667f774bb748e91 SHA512 9a1777da96fbde00669586899658d63a64b19252e90a01ccc0440e0f79f948ddd9dc118774365e227a75b80edf4c784760164268efb2d1f69000fe68ac5eb5b9
diff --git a/dev-libs/ftl/ftl-1.0_p20210308.ebuild b/dev-libs/ftl/ftl-1.0_p20210308.ebuild
new file mode 100644
index 0000000000..4cdbc8837f
--- /dev/null
+++ b/dev-libs/ftl/ftl-1.0_p20210308.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_STANDARD="2003"
+
+inherit fortran-2 toolchain-funcs
+
+COMMIT="97b8292e893ad147ca44e42bcd56d23e9a8259fb"
+DESCRIPTION="The Fortran Template Library (FTL) is a general purpose library for Fortran 2003"
+HOMEPAGE="https://github.com/SCM-NV/ftl/"
+SRC_URI="https://github.com/SCM-NV/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pcre test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( pcre )" # Some tests fail if 'pcre' is disabled
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Replase install PREFIX, LIBDIR, add library soname
+ sed -i -e 's:PREFIX ?= /usr/local:PREFIX ?= '"${ED}"'/usr/:' \
+ -e 's:(PREFIX)/lib:(PREFIX)/'"$(get_libdir)"':' \
+ -e 's:SOLDFLAGS = -shared:SOLDFLAGS = -shared -Wl,-soname=libftl.so.1 '"${LDFLAGS}"':' makefile || die
+}
+
+src_configure() {
+ return 0
+}
+
+src_compile() {
+ emake \
+ BUILD=release \
+ USE_PCRE=$(usex pcre true false) \
+ COMPILER="$(tc-getFC)" \
+ FLAGS="${FCFLAGS}" \
+ CXXCOMPILER="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake install
+
+ mv "${ED}/usr/$(get_libdir)"/libftl.so{,.1} || die
+ dosym libftl.so.1 /usr/$(get_libdir)/libftl.so
+}
diff --git a/dev-libs/ftl/metadata.xml b/dev-libs/ftl/metadata.xml
new file mode 100644
index 0000000000..8f6288baf0
--- /dev/null
+++ b/dev-libs/ftl/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>torokhov-s-a@yandex.ru</email>
+ <name>Sergey Torokhov</name>
+ </maintainer>
+ <longdescription>
+ The Fortran Template Library (FTL) is a general purpose library for Fortran 2003.
+ Its intention is to bring all these nice things we take for granted in modern languages
+ like Python and C++ to the Fortran world: Generic containers, versatile algorithms,
+ easy string manipulation, and more.
+ It is heavily inspired by C++'s standard library,
+ especially the part that is commonly referred to as the Standard Template Library (STL).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">SCM-NV/ftl</remote-id>
+ </upstream>
+</pkgmetadata>