aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-04-30 22:12:05 -0400
committerAisha Tammy <gentoo@aisha.cc>2021-04-30 22:12:05 -0400
commitb246bafe90af9be9fbe254065091e6d7f383de38 (patch)
tree38e133560ccc53cf5cce19f6468c03bfe086a417
parentmedia-libs/libbpg: Add -lnuma to X265_LIBS instead of to LIBS. (diff)
downloadguru-b246bafe.tar.gz
guru-b246bafe.tar.bz2
guru-b246bafe.zip
net-misc/purritobin: version bump to 0.6.2
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--net-misc/purritobin/Manifest1
-rw-r--r--net-misc/purritobin/purritobin-0.6.2.ebuild56
-rw-r--r--net-misc/purritobin/purritobin-9999.ebuild7
3 files changed, 62 insertions, 2 deletions
diff --git a/net-misc/purritobin/Manifest b/net-misc/purritobin/Manifest
index abb8427be..83b03d43d 100644
--- a/net-misc/purritobin/Manifest
+++ b/net-misc/purritobin/Manifest
@@ -1 +1,2 @@
DIST purritobin-0.5.2.tar.gz 18272 BLAKE2B f5f93a5c6bb189e232cd6eaa05c1c914fa48d5b767697064e238ed1fc83224b6457e452b459c5d62dd17c12454cee43b08ed916589237aca5ab6d04968e653bd SHA512 13bb3c2a1382ae1a45922a997852db573517dd7a8ff6145b349ab62632fa6bdcd2441c6559baf375286c615a72e7bdf065de3fbcb164aee2a8408f17deade629
+DIST purritobin-0.6.2.tar.gz 18849 BLAKE2B e8fa83913d82ccbdc42c9b54f1e0b801203151b5ea89ad94bb2eaaf964cbc594e2cc8fa651dd61d14ee33729fd52fb5475cbc2003edbf766d831f48ca25c1753 SHA512 52d751808070eb46c683115f1981131386114d1a1450ab24c1ac7b341d1c6cbe3319cf55b5a85bf35a0903d1cc4cdb144f6bbe2e5b72bcc358c5f6fccdae5553
diff --git a/net-misc/purritobin/purritobin-0.6.2.ebuild b/net-misc/purritobin/purritobin-0.6.2.ebuild
new file mode 100644
index 000000000..854dabc82
--- /dev/null
+++ b/net-misc/purritobin/purritobin-0.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="minimalistic commandline pastebin"
+HOMEPAGE="https://bsd.ac"
+
+inherit systemd toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PurritoBin/PurritoBin.git"
+else
+ SRC_URI="https://github.com/PurritoBin/PurritoBin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PurritoBin-${PV}"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.29
+ net-libs/usockets[ssl]
+ acct-user/purritobin
+ acct-group/purritobin
+"
+DEPEND="${RDEPEND}
+ www-apps/uwebsockets
+ >=dev-db/lmdb++-1.0.0
+"
+BDEPEND="test? ( sys-apps/coreutils )"
+
+src_configure() {
+ default
+ tc-export CXX
+}
+
+src_test() {
+ P_DD_FLAGS="iflag=fullblock" \
+ default
+}
+
+src_install() {
+ emake PREFIX="/usr" MANDIR="/usr/share/man" DESTDIR="${ED}" install
+ insinto /var/www/purritobin
+ doins frontend/paste.html
+ keepdir /var/db/purritobin
+ fowners purritobin:purritobin /var/www/purritobin /var/db/purritobin
+ newinitd services/openrc purritobin
+ systemd_newunit services/systemd purritobin.service
+ einstalldocs
+}
diff --git a/net-misc/purritobin/purritobin-9999.ebuild b/net-misc/purritobin/purritobin-9999.ebuild
index f817ccf8e..854dabc82 100644
--- a/net-misc/purritobin/purritobin-9999.ebuild
+++ b/net-misc/purritobin/purritobin-9999.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/PurritoBin/PurritoBin.git"
else
SRC_URI="https://github.com/PurritoBin/PurritoBin/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/PurritoBin-${PV}"
fi
@@ -23,12 +23,14 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
+ >=dev-db/lmdb-0.9.29
net-libs/usockets[ssl]
acct-user/purritobin
acct-group/purritobin
"
DEPEND="${RDEPEND}
www-apps/uwebsockets
+ >=dev-db/lmdb++-1.0.0
"
BDEPEND="test? ( sys-apps/coreutils )"
@@ -46,7 +48,8 @@ src_install() {
emake PREFIX="/usr" MANDIR="/usr/share/man" DESTDIR="${ED}" install
insinto /var/www/purritobin
doins frontend/paste.html
- fowners purritobin:purritobin /var/www/purritobin
+ keepdir /var/db/purritobin
+ fowners purritobin:purritobin /var/www/purritobin /var/db/purritobin
newinitd services/openrc purritobin
systemd_newunit services/systemd purritobin.service
einstalldocs