aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2021-10-08 21:40:51 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2021-10-08 21:45:37 +0200
commitb24dc12afb80100f3b46142529d21c3a1145dd9d (patch)
treeb8bc881b7abb462ec074a436b64f5a9f8e317f16
parentdev-scheme/chibi: fix usage of D inside src_configure (diff)
downloadguru-b24dc12afb80100f3b46142529d21c3a1145dd9d.tar.gz
guru-b24dc12afb80100f3b46142529d21c3a1145dd9d.tar.bz2
guru-b24dc12afb80100f3b46142529d21c3a1145dd9d.zip
dev-python/urlmatch: new package (1.0.1)
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
-rw-r--r--dev-python/urlmatch/Manifest1
-rw-r--r--dev-python/urlmatch/metadata.xml8
-rw-r--r--dev-python/urlmatch/urlmatch-1.0.1.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/urlmatch/Manifest b/dev-python/urlmatch/Manifest
new file mode 100644
index 000000000..6c7d55d3c
--- /dev/null
+++ b/dev-python/urlmatch/Manifest
@@ -0,0 +1 @@
+DIST urlmatch-1.0.1.tar.gz 4852 BLAKE2B 564784d2d6555cab8193136e7626e7c2f9766823faf69de50985a140c72e707b89adf8916915dc4f3e94d389638873a272f6d78b867ae391791dbd9b4fa4c4ae SHA512 f5dc2bae59db0e193de4e5ec5bf7f074da60b925a09d8f466cf29f73ca7bebbe59a63c65d3b361e9dc475aac528f7990ec23fdc73fc24de260fe9f2447e287e0
diff --git a/dev-python/urlmatch/metadata.xml b/dev-python/urlmatch/metadata.xml
new file mode 100644
index 000000000..cbe3c6a53
--- /dev/null
+++ b/dev-python/urlmatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>smaniotto.nicola@gmail.com</email>
+ <name>Nicola Smaniotto</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/urlmatch/urlmatch-1.0.1.ebuild b/dev-python/urlmatch/urlmatch-1.0.1.ebuild
new file mode 100644
index 000000000..f94bde28e
--- /dev/null
+++ b/dev-python/urlmatch/urlmatch-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for easily pattern matching wildcard URLs"
+HOMEPAGE="https://github.com/jessepollak/urlmatch"
+SRC_URI="https://github.com/jessepollak/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+src_prepare(){
+ sed 's/find_packages()/find_packages(exclude=["tests*"])/' -i setup.py || die
+ default
+}
+
+python_test(){
+ eunittest tests/ "*.py"
+}