aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-05-02 00:40:43 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-05-02 00:40:43 +0500
commitb451a988ba75f9ea0ca918233b01d7e0e5c7fd83 (patch)
tree46517b8d2d15d3a7dc06663842cf2638dfd6a5ce
parentdev-python/pyinstaller: treeclean (diff)
downloadguru-b451a988ba75f9ea0ca918233b01d7e0e5c7fd83.tar.gz
guru-b451a988ba75f9ea0ca918233b01d7e0e5c7fd83.tar.bz2
guru-b451a988ba75f9ea0ca918233b01d7e0e5c7fd83.zip
dev-python/redbaron: treeclean
Closes: https://bugs.gentoo.org/862507 Closes: https://bugs.gentoo.org/897572 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-python/redbaron/Manifest2
-rw-r--r--dev-python/redbaron/metadata.xml9
-rw-r--r--dev-python/redbaron/redbaron-0.9.2.ebuild38
-rw-r--r--dev-python/redbaron/redbaron-0.9.ebuild39
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/redbaron/Manifest b/dev-python/redbaron/Manifest
deleted file mode 100644
index fc44a7a90..000000000
--- a/dev-python/redbaron/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST redbaron-0.9.2.tar.gz 709401 BLAKE2B 06be75576fafd9ca69fd4f46bbeead0c9a8691c49ab233a53e91e462f87a48e0fdd4b314bb23fa91fb60ea022fe535b89371fb1f82418240117d50e214125e45 SHA512 a91670b0c48ac399ea9a000be42f1d4d4451ec39b58b2a7029a3bcdf664136dab3ff8e81284b384ddabfb77a5fa43ce4d75041d3aed5685d451ab620dfa23e9a
-DIST redbaron-0.9.tar.gz 708544 BLAKE2B e3314a29e66fe2e91ef28183f5e9f6c91117963bfffa0bcc1fb62602bc87b1c5fcf058ff545c3515e0de8077f70298aa788960e7409cbde6a0199701947786f6 SHA512 db99be12a1a0a3caab80f8b319d2966ffe5f80b15e5f838212bdb327c75c411ee273b4ff44dae76010165bd563275eb50c8c5b8d87284a493114224603e9cb25
diff --git a/dev-python/redbaron/metadata.xml b/dev-python/redbaron/metadata.xml
deleted file mode 100644
index b8d978ae1..000000000
--- a/dev-python/redbaron/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">PyCQA/redbaron</remote-id>
- <remote-id type="pypi">redbaron</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/redbaron/redbaron-0.9.2.ebuild b/dev-python/redbaron/redbaron-0.9.2.ebuild
deleted file mode 100644
index ab2d09270..000000000
--- a/dev-python/redbaron/redbaron-0.9.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A FST for python to make writing refactoring code a realistic task"
-HOMEPAGE="
- https://redbaron.readthedocs.io/
- https://github.com/PyCQA/redbaron
-"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/baron-0.7[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-distutils_enable_sphinx docs dev-python/ipython
-
-python_prepare_all() {
- # Remove "__pycache__". Reason: unique basename
- rm -rfd "${S}"/tests/__pycache__ || die
-
- # Skip tests. Reason: calls fixture "red" directly
- rm "${S}"/tests/test_bounding_box.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/redbaron/redbaron-0.9.ebuild b/dev-python/redbaron/redbaron-0.9.ebuild
deleted file mode 100644
index b9caa47aa..000000000
--- a/dev-python/redbaron/redbaron-0.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-
-inherit distutils-r1
-
-DESCRIPTION="A FST for python to make writing refactoring code a realistic task"
-HOMEPAGE="
- https://redbaron.readthedocs.io/
- https://github.com/PyCQA/redbaron
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/baron-0.7[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-distutils_enable_sphinx docs dev-python/ipython
-
-python_prepare_all() {
- # Remove "__pycache__". Reason: unique basename
- rm -rfd "${S}"/tests/__pycache__ || die
-
- # Skip tests. Reason: calls fixture "red" directly
- rm "${S}"/tests/test_bounding_box.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 90ea0fdbc..fc2b431cb 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -22,7 +22,6 @@ sys-cluster/pcs
# Anna Vyalkova <cyber+gentoo@sysrq.in> (2023-05-01)
# No supported Pythom implementations set in ebuild.
# Masked for removal in 30 days.
-dev-python/redbaron
dev-util/osc
gui-apps/azote
net-wireless/iwdgui