aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2020-12-05 19:10:34 +0500
committerDenis Reva <denis7774@gmail.com>2020-12-05 19:10:34 +0500
commitb4ee7252ca72f035b49b55917ac6386c3a673964 (patch)
tree8f3e2b346a44f2530ed5fb6a23d4ecd586b1eff9
parentx11-themes/arc-darkest-colors: Remove old ebuild. (diff)
downloadguru-b4ee7252.tar.gz
guru-b4ee7252.tar.bz2
guru-b4ee7252.zip
sys-fs/erofs-utils: user-space utilities for erofs
New package, taken from https://bugs.gentoo.org/701284 Added metadata.xml. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Denis Reva <denis7774@gmail.com>
-rw-r--r--sys-fs/erofs-utils/Manifest1
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.1.ebuild33
-rw-r--r--sys-fs/erofs-utils/metadata.xml36
3 files changed, 70 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/Manifest b/sys-fs/erofs-utils/Manifest
new file mode 100644
index 000000000..3bf92e0bf
--- /dev/null
+++ b/sys-fs/erofs-utils/Manifest
@@ -0,0 +1 @@
+DIST erofs-utils-1.1.tar.gz 46133 BLAKE2B 24a2f16059e39bd65203f4a28721b8aad70599d6201ead02c291234de631bd3def1c403fa8b50b6dce4af3eea2768b912c4f56ad20c3c26db3853ba3174775ac SHA512 f300b536f0ba91a05a7eb3dc9a9ec402c98966ad7c0e1f2f664a650caaffce6c4433722374418c6d03e69ce2e74785e55f9bcc45e6717a8bc67e5352e450806b
diff --git a/sys-fs/erofs-utils/erofs-utils-1.1.ebuild b/sys-fs/erofs-utils/erofs-utils-1.1.ebuild
new file mode 100644
index 000000000..272f9f803
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS images"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+SRC_URI="${HOMEPAGE}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="lz4 +uuid"
+
+RDEPEND="
+ lz4? ( >=app-arch/lz4-1.9 )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lz4) \
+ $(use_with uuid)
+}
diff --git a/sys-fs/erofs-utils/metadata.xml b/sys-fs/erofs-utils/metadata.xml
new file mode 100644
index 000000000..e4bdaaa46
--- /dev/null
+++ b/sys-fs/erofs-utils/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ <description>Partial maintainer</description>
+ </maintainer>
+ <longdescription lang="en">
+ erofs-utils
+ ===========
+ erofs-utils includes user-space tools for erofs filesystem images.
+ Currently only mkfs.erofs is available.
+
+ Mkfs.erofs
+ ----------
+ It can create 2 primary kinds of erofs images: (un)compressed.
+ - For compressed images, it's able to use several compression algorithms, but lz4(hc) are only supported due to the current linux kernel implementation.
+ - For uncompressed images, it can decide whether the last page of a file should be inlined or not properly [1].
+ How to generate erofs images
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ Currently lz4 and lz4hc are available for compression, e.g.
+ $ mkfs.erofs -zlz4hc foo.erofs.img foo/
+ Or leave all files uncompressed as a option:
+ $ mkfs.erofs foo.erofs.img foo/
+
+ Known issues
+ ~~~~~~~~~~~~
+ 1. LZ4HC cannot compress long zeroed buffer properly with
+ LZ4_compress_HC_destSize()
+ https://github.com/lz4/lz4/issues/784
+ </longdescription>
+ <use>
+ <flag name="uuid">Allow interaction with libuuid in sys-apps/util-linux. It's recommended turn on</flag>
+ </use>
+</pkgmetadata>