aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-03-10 07:37:57 -0500
committerAisha Tammy <gentoo@aisha.cc>2021-03-10 07:37:57 -0500
commitb63c82cd36a8cde5b0929fb5ad28275d9a4365ce (patch)
tree3c61c2cb3083979e0fd1f90634321eb3def1668a
parentsci-electronics/verilator: drop 4.108 (diff)
downloadguru-b63c82cd36a8cde5b0929fb5ad28275d9a4365ce.tar.gz
guru-b63c82cd36a8cde5b0929fb5ad28275d9a4365ce.tar.bz2
guru-b63c82cd36a8cde5b0929fb5ad28275d9a4365ce.zip
gui-apps/wdisplays: fix dependencies
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--gui-apps/wdisplays/wdisplays-1.0-r3.ebuild35
-rw-r--r--gui-apps/wdisplays/wdisplays-9999.ebuild28
2 files changed, 53 insertions, 10 deletions
diff --git a/gui-apps/wdisplays/wdisplays-1.0-r3.ebuild b/gui-apps/wdisplays/wdisplays-1.0-r3.ebuild
new file mode 100644
index 000000000..e9c017e2e
--- /dev/null
+++ b/gui-apps/wdisplays/wdisplays-1.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg
+
+DESCRIPTION="GUI display configurator for wlroots compositors"
+HOMEPAGE="https://cyclopsian.github.io/wdisplays https://github.com/cyclopsian/wdisplays"
+
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cyclopsian/wdisplays.git"
+else
+ SRC_URI="https://github.com/cyclopsian/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ dev-libs/glib
+ media-libs/libepoxy
+ x11-libs/gtk+:3[wayland]
+ x11-libs/cairo
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0-pull20.patch" )
diff --git a/gui-apps/wdisplays/wdisplays-9999.ebuild b/gui-apps/wdisplays/wdisplays-9999.ebuild
index 3959f430e..e9c017e2e 100644
--- a/gui-apps/wdisplays/wdisplays-9999.ebuild
+++ b/gui-apps/wdisplays/wdisplays-9999.ebuild
@@ -1,27 +1,35 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit meson xdg
+
+DESCRIPTION="GUI display configurator for wlroots compositors"
+HOMEPAGE="https://cyclopsian.github.io/wdisplays https://github.com/cyclopsian/wdisplays"
+
if [[ "${PV}" == 9999 ]]
then
inherit git-r3
EGIT_REPO_URI="https://github.com/cyclopsian/wdisplays.git"
else
SRC_URI="https://github.com/cyclopsian/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
-inherit meson xdg
-DESCRIPTION="GUI display configurator for wlroots compositors"
-HOMEPAGE="https://cyclopsian.github.io/wdisplays https://github.com/cyclopsian/wdisplays"
-
-BDEPEND="
+RDEPEND="
+ dev-libs/glib
+ media-libs/libepoxy
x11-libs/gtk+:3[wayland]
- gui-libs/wlroots"
-DEPEND="${BDEPEND}"
+ x11-libs/cairo
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+"
LICENSE="GPL-3+"
SLOT="0"
-PATCHES=("${FILESDIR}/${PN}-1.0-pull20.patch")
+PATCHES=( "${FILESDIR}/${PN}-1.0-pull20.patch" )