aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-27 17:37:59 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-27 17:38:20 +0200
commitb7524220f5cc44d0d0c690b2bcb1f93872ab6188 (patch)
tree081f66ee9cb82bd91f438d60cf8b805dac72cf7a
parent*/*: Upgrade to https when available (diff)
downloadguru-b7524220.tar.gz
guru-b7524220.tar.bz2
guru-b7524220.zip
dev-python/trio-asyncio: move to ::gentoo
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/pytest-trio/Manifest1
-rw-r--r--dev-python/pytest-trio/metadata.xml13
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild55
-rw-r--r--dev-python/trio-asyncio/Manifest1
-rw-r--r--dev-python/trio-asyncio/files/no-pytest-runner.patch10
-rw-r--r--dev-python/trio-asyncio/metadata.xml27
-rw-r--r--dev-python/trio-asyncio/trio-asyncio-0.12.0.ebuild36
7 files changed, 0 insertions, 143 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
deleted file mode 100644
index e39be86a7..000000000
--- a/dev-python/pytest-trio/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
diff --git a/dev-python/pytest-trio/metadata.xml b/dev-python/pytest-trio/metadata.xml
deleted file mode 100644
index 0cc4d7f61..000000000
--- a/dev-python/pytest-trio/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <description>co-maintainers welcome</description>
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <upstream>
- <remote-id type="github">python-trio/pytest-trio</remote-id>
- <remote-id type="pypi">pytest-trio</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
deleted file mode 100644
index a56157c2f..000000000
--- a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-DOCS_BUILDER="sphinx"
-DOCS_DIR="${S}/docs/source"
-DOCS_DEPEND="
- >=dev-python/attrs-17.4.0
- >=dev-python/sphinx-1.6.1
- dev-python/sphinx_rtd_theme
- dev-python/sphinxcontrib-trio
-"
-
-inherit distutils-r1 docs
-
-DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
-HOMEPAGE="
- https://github.com/python-trio/pytest-trio
- https://pypi.org/project/pytest-trio
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS="~amd64"
-#too many errors
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/trio-0.15[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- <dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # has to be run in source dir
- #even upstream doesn't know how to run their tests
- #https://github.com/python-trio/pytest-trio/issues/84
- #"Our CI is still passing AFAIK"
- PYTHONPATH="${S}"
- cd "${S}" || die
- pytest -vv --pyargs pytest_trio || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/trio-asyncio/Manifest b/dev-python/trio-asyncio/Manifest
deleted file mode 100644
index a4fd46342..000000000
--- a/dev-python/trio-asyncio/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST trio-asyncio-0.12.0.tar.gz 72508 BLAKE2B f2dad48e20dadb81f603f8e7edf5d108f5c1dec332e65599e06495a9e3b919d20a15e3cb0d4f06c46a0e844cd79a88c172043b5cae2bc632661679a9ac854c04 SHA512 da630bf95d0736efd419a7b84d3fcb55f4440ef5f3ac584f36b2eca9188145d4581b20d4842b1322b07f176822f7c76e32ae57ac71899ea2445ce1783bcd382c
diff --git a/dev-python/trio-asyncio/files/no-pytest-runner.patch b/dev-python/trio-asyncio/files/no-pytest-runner.patch
deleted file mode 100644
index 6eec59da4..000000000
--- a/dev-python/trio-asyncio/files/no-pytest-runner.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/setup.py 2021-03-27 18:54:07.104800689 +0100
-+++ b/setup.py 2021-03-27 18:54:23.197091635 +0100
-@@ -77,7 +77,6 @@
- include_package_data=True,
- python_requires=">=3.6", # temporary, for RTD
- keywords=["async", "io", "trio", "asyncio", "trio-asyncio"],
-- setup_requires=['pytest-runner'],
- tests_require=['pytest >= 5.4', 'pytest-trio >= 0.6', 'outcome'],
- classifiers=[
- "Development Status :: 4 - Beta",
diff --git a/dev-python/trio-asyncio/metadata.xml b/dev-python/trio-asyncio/metadata.xml
deleted file mode 100644
index f34dda2d3..000000000
--- a/dev-python/trio-asyncio/metadata.xml
+++ /dev/null
@@ -1,27 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-
-<pkgmetadata>
- <maintainer type="person">
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <longdescription lang="en">
-Rationale
-
-Trio has native concepts of tasks and task cancellation. Asyncio is based on callbacks and chaining Futures, albeit with nicer syntax, which make handling of failures and timeouts fundamentally less reliable, especially in larger programs. Thus, you really want to base your async project on Trio.
-
-On the other hand, there are quite a few asyncio-enhanced libraries. You really don't want to re-invent any wheels in your project.
-
-Thus, being able to use asyncio libraries from Trio is useful. trio-asyncio enables you to do that, and more.
-Transparent vs. explicit translation
-
-trio_asyncio does not try to magically allow calling await trio_code() from asyncio or vice versa. There are multiple reasons for this; the executive summary is that cross-domain calls can't be made to work correctly, and any such call is likely to result in an irrecoverable error. You need to keep your code's asyncio and trio domains rigidly separate.
-
-Fortunately, this is not difficult.
- </longdescription>
- <upstream>
- <remote-id type="github">python-trio/trio-asyncio</remote-id>
- <remote-id type="pypi">trio-asyncio</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/trio-asyncio/trio-asyncio-0.12.0.ebuild b/dev-python/trio-asyncio/trio-asyncio-0.12.0.ebuild
deleted file mode 100644
index ac86ace5e..000000000
--- a/dev-python/trio-asyncio/trio-asyncio-0.12.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="a re-implementation of the asyncio mainloop on top of Trio"
-HOMEPAGE="
- https://github.com/python-trio/trio-asyncio
- https://pypi.org/project/trio-asyncio
-"
-SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/outcome[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- >=dev-python/trio-0.15.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-trio-0.6[${PYTHON_USEDEP}]
- )
-"
-PATCHES=( "${FILESDIR}/no-pytest-runner.patch" )
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio