aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-03 00:58:21 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-04 01:46:07 +0200
commitb757bc38565c237089df454046f794d870f72969 (patch)
tree985a39b145a34ddf5b020f168afd778f87e6559d
parentdev-ml/uri: initial import (diff)
downloadguru-b757bc38.tar.gz
guru-b757bc38.tar.bz2
guru-b757bc38.zip
dev-ml/xapi-stdext: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-ml/xapi-stdext/Manifest1
-rw-r--r--dev-ml/xapi-stdext/metadata.xml11
-rw-r--r--dev-ml/xapi-stdext/xapi-stdext-4.18.0.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/xapi-stdext/Manifest b/dev-ml/xapi-stdext/Manifest
new file mode 100644
index 000000000..f4e06be83
--- /dev/null
+++ b/dev-ml/xapi-stdext/Manifest
@@ -0,0 +1 @@
+DIST xapi-stdext-4.18.0.tar.gz 52297 BLAKE2B f0f4e0f2453b9d98a0fcbd90437cc173771164f18dca3dcc7a05afe1ddccb14a08f192184ab9bddbcfca14f8687cd935000c0ad26ea4adceece51df712cf5579 SHA512 11267f9adc7676724ef7e0a0e1eb670c7234216d45d9566eb09fafe09728c9da5d1ac065afa5aec73895c81d6e62f1c16cabc48c7c6473002e0d58fd7dbc97ee
diff --git a/dev-ml/xapi-stdext/metadata.xml b/dev-ml/xapi-stdext/metadata.xml
new file mode 100644
index 000000000..2b8c3392c
--- /dev/null
+++ b/dev-ml/xapi-stdext/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xapi-project/stdext</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/xapi-stdext/xapi-stdext-4.18.0.ebuild b/dev-ml/xapi-stdext/xapi-stdext-4.18.0.ebuild
new file mode 100644
index 000000000..79e88891d
--- /dev/null
+++ b/dev-ml/xapi-stdext/xapi-stdext-4.18.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Citrix's (deprecated) extensions to the ocaml standard library"
+HOMEPAGE="
+ https://xapi-project.github.io/stdext/
+ https://github.com/xapi-project/stdext
+"
+SRC_URI="https://github.com/xapi-project/stdext/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/stdext-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+DEPEND="
+ <dev-lang/ocaml-4.14.0
+ dev-ml/astring
+ dev-ml/fd-send-recv
+ dev-ml/logs
+ dev-ml/ptime
+ dev-ml/xapi-backtrace
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune_src_install xapi-stdext-date
+ dune_src_install xapi-stdext-encodings
+ dune_src_install xapi-stdext-pervasives
+ dune_src_install xapi-stdext-std
+ dune_src_install xapi-stdext-threads
+ dune_src_install xapi-stdext-unix
+ dune_src_install xapi-stdext-zerocheck
+}