aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-27 12:04:59 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-27 14:50:05 +0500
commitb884f8c647d5aaf0d5d6df116d3a56ce2137e5c5 (patch)
tree1d8fd6e5786706ad9a0a90eb12244ee1859514d8
parentdev-crystal/crystal-db: add 0.13.1, drop 0.12.0 (diff)
downloadguru-b884f8c647d5aaf0d5d6df116d3a56ce2137e5c5.tar.gz
guru-b884f8c647d5aaf0d5d6df116d3a56ce2137e5c5.tar.bz2
guru-b884f8c647d5aaf0d5d6df116d3a56ce2137e5c5.zip
dev-crystal/crystal-pg: add 0.28.0, drop 0.27.0
Closes: https://bugs.gentoo.org/922917 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-crystal/crystal-pg/Manifest2
-rw-r--r--dev-crystal/crystal-pg/crystal-pg-0.28.0.ebuild (renamed from dev-crystal/crystal-pg/crystal-pg-0.27.0.ebuild)24
2 files changed, 15 insertions, 11 deletions
diff --git a/dev-crystal/crystal-pg/Manifest b/dev-crystal/crystal-pg/Manifest
index 5c1053bf8..8482d9a88 100644
--- a/dev-crystal/crystal-pg/Manifest
+++ b/dev-crystal/crystal-pg/Manifest
@@ -1,2 +1,2 @@
DIST crystal-pg-0.26.0.tar.gz 38901 BLAKE2B 954737db2ebfb02ad8ed7a071a2728199a306a8eb44a31bd7702413d271c8e9aec4d5ff104487d224e8278bb4d45fe619e8f84db930cd3c70a83a3487b6387bc SHA512 097450dbabb2c2d26deb70a9ed34f49f70e63e59055b5b3513eab9951feca546886998263848c7b7648bad716f6d67b436d1bde5ff0a89d521520350138055c1
-DIST crystal-pg-0.27.0.tar.gz 44125 BLAKE2B d14a09318eb2b5bc7629a320456ac291c0aa1370b7155592216a259f0f1d3abd7770926bb6ec30bb3f816f219770b23e050383342088844cc95182e6bdf98916 SHA512 8705f2db8e935e090d81bb19e9d1b25870ade8592dac15b007387233e90af226e9610fd549c331e543b14ec5284cd00d14712d5a8727dd2d2fedc0b55420767f
+DIST crystal-pg-0.28.0.tar.gz 44534 BLAKE2B 69f3c50e77c928055bc66ef46b729052e6c0df69a80c310bf576ed75d51a5f3a93ebb4faa10c47c8a64dc4f46fcecf2b5b82e9812d5b6839ba5f6888cf5e5bd9 SHA512 34358bc203b78fcbe3828d086dbf31b09b94e465f5c179c6a35186f2f5d42a65cd362ef75860e93eb3252699cc22787f798e09484f2e20d1284db6a384721a78
diff --git a/dev-crystal/crystal-pg/crystal-pg-0.27.0.ebuild b/dev-crystal/crystal-pg/crystal-pg-0.28.0.ebuild
index 64a8e19c6..8bbdc3de2 100644
--- a/dev-crystal/crystal-pg/crystal-pg-0.27.0.ebuild
+++ b/dev-crystal/crystal-pg/crystal-pg-0.28.0.ebuild
@@ -1,9 +1,12 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit databases edo shards
+declare -Ag DAEMONS_REQ_USE=(
+ [postgresql]="xml"
+)
+inherit daemons shards
DESCRIPTION="A native, non-blocking Postgres driver for Crystal"
HOMEPAGE="https://github.com/will/crystal-pg"
@@ -12,19 +15,20 @@ SRC_URI="https://github.com/will/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.t
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-crystal/crystal-db"
-BDEPEND="test? ( ${DATABASES_DEPEND[postgres]} )"
+RDEPEND="
+ >=dev-crystal/crystal-db-0.13.0
+ <dev-crystal/crystal-db-0.14.0
+"
DOCS=( CHANGELOG CONTRIBUTORS {CONTRIBUTING,README}.md )
+daemons_enable postgresql test
+
src_test() {
- local -x DATABASE_URL="postgres://postgres@127.0.0.1:65432/testdb"
+ daemons_start postgresql --host 127.0.0.1
+ local -x DATABASE_URL="${POSTGRESQL_URL:?}"
- epostgres --start 65432
- edo createdb -h 127.0.0.1 -p 65432 -U postgres testdb
shards_src_test
- epostgres --stop
+ daemons_stop postgresql
}