aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Nicolas <patricknicolas@laposte.net>2024-02-18 17:14:32 +0100
committerPatrick Nicolas <patricknicolas@laposte.net>2024-02-18 17:15:23 +0100
commitb8f241c12ec237d76195bfd23401ef56e0c8f030 (patch)
tree940937e5503607ea501fd46d468d51d8cb1c85ac
parentmedia-libs/wivrn: drop 0.9.1 (diff)
downloadguru-b8f241c1.tar.gz
guru-b8f241c1.tar.bz2
guru-b8f241c1.zip
media-libs/wivrn: add 0.11
Signed-off-by: Patrick Nicolas <patricknicolas@laposte.net>
-rw-r--r--media-libs/wivrn/Manifest4
-rw-r--r--media-libs/wivrn/wivrn-0.11.ebuild100
-rw-r--r--media-libs/wivrn/wivrn-9999.ebuild4
3 files changed, 105 insertions, 3 deletions
diff --git a/media-libs/wivrn/Manifest b/media-libs/wivrn/Manifest
index 5fecb1ed0..39c47b2c7 100644
--- a/media-libs/wivrn/Manifest
+++ b/media-libs/wivrn/Manifest
@@ -1,4 +1,6 @@
DIST boostpfr_2.0.3.tar.gz 57376 BLAKE2B 447370c88a3241fcd91d5fb4c3ea8a6b5e54e11807f0b0458da8ba26a7a57d54402403d13c951ebdf3638386f01bd721fc50558477802a8aae3012ee6e88cba5 SHA512 ce7a7955066a678cfff3d65068830b60727dc6a0a1c3f29a1b1fcb50c79f718fb06d6767afb74f7e9ce00f33858cd10f627534f29f536e5504f034831c696ca0
-DIST monado-79bf8eb8fa168f65f4e5505e0525ee74aa88783e.tar.gz 3295316 BLAKE2B 8f52e770999c0dfef2082e55edb0a08bcbce06fc2dbeb70627cd820921c1006e39b5d8498b1c4442ecac900ca6cf2c27dde58f3d8dccd0dd2c52cbed01aca297 SHA512 736e186f17f03601064512d1f1a54aa7a9453c416e213c8014b932a6182ee2b773a1994f6980632a1ce043e35f092307f575005ef230988c5e2f23dd6df4a134
+DIST monado-57e937383967c7e7b38b5de71297c8f537a2489d.tar.gz 3324809 BLAKE2B 0ea1b7c7ae5717069a4e86e581264a271e9dea39721e27599453bef12ef5963a50db7ce4d5c2c9db4dcd699438bde74e219a60fb3b0e453e4128b16821e7f1de SHA512 0d51753615e6b9fd98d2dd6eb95b324d35f05cd45f2f738bd8480890ce730aabdee37ec603e6fc248d88e426c727c8ac7f9cf2a47e15d182a36f319891799241
DIST wivrn-0.10.1-server-build-deps.tar.xz 16181364 BLAKE2B ef0f9855fc454d7258846bcc1c4a94f5d15570c2e092dc7913c93935cd2c343cfeaf2b585dcde32344781c2e03e91fa4a506708729f1032bc883ae2cc17f840e SHA512 629e47ef07280f0048ae8c534bf3a503a142d6ba878bf2cf2aeb77fd58027c85add2796fa2cac871baa0c0feb51d402362728335e3c9ebb2943e1f5e59abef19
DIST wivrn-0.10.1.tar.gz 393044 BLAKE2B a452d78a7a1a25e33a7fa4c75b32c3b1c05a3118d56db140f3ffb27698511c3bd2dd6e910826eb745aa77f3acc1caddaec083c08605f98fd8cb0a5e195384b87 SHA512 3448f35b6820afb184cf078379fe090fe73749cddab4d907bb7e5560c5d2117813a6290e47313ca12db215402039097cb51d5fc7c73baac77ad61e8ef5607b1a
+DIST wivrn-0.11-server-build-deps.tar.xz 16544220 BLAKE2B dc04c6a414c8146c66bb18a3ad89cb7deaa378e838a9877675307c44ec26e7fb09fa653c947b72343fab210bcb43bd72e7a1a1012dc4f4c39c59f6316e2fe48c SHA512 1eacc7ffb6de88944dc057cc41e7e17805dbd56e72f32d13a47877a62a3a4c916cfd343e813e20656c913c9c4e4f7b5e4bc8571eb9cb442074cdeeba3ec75671
+DIST wivrn-0.11.tar.gz 11675453 BLAKE2B 2bfd6719b969dacaba0bb461415de000d11bdc249db148a7f621827592d69a65d23af0481a93601b9d381a253bc3c86aaa37af02e931d68b5a3c1cf777f5862e SHA512 00764283a09fc07e21f9a59970a2fb256c225da95b3b2ca858c0d740e633b3f6391521dd05458b8901ad2a764675e4cac01caadac4f99f3311236a424b8e4349
diff --git a/media-libs/wivrn/wivrn-0.11.ebuild b/media-libs/wivrn/wivrn-0.11.ebuild
new file mode 100644
index 000000000..a254c95c2
--- /dev/null
+++ b/media-libs/wivrn/wivrn-0.11.ebuild
@@ -0,0 +1,100 @@
+EAPI=7
+
+DESCRIPTION="WiVRn OpenXR streaming"
+HOMEPAGE="https://github.com/meumeu/WiVRn"
+SLOT="0"
+LICENSE="GPL-3 Apache-2.0 MIT"
+
+IUSE="nvenc systemd vaapi x264"
+REQUIRED_USE="|| ( nvenc vaapi x264 )"
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Meumeu/WiVRn.git"
+
+ MONADO_V=57e937383967c7e7b38b5de71297c8f537a2489d
+ PFR_V=2.0.3
+ SRC_URI="
+ https://github.com/boostorg/pfr/archive/refs/tags/${PFR_V}.tar.gz -> boostpfr_${PFR_V}.tar.gz
+ https://gitlab.freedesktop.org/monado/monado/-/archive/${MONADO_V}/monado-${MONADO_V}.tar.gz"
+else
+ SRC_URI="
+ https://github.com/Meumeu/WiVRn/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Meumeu/WiVRn/releases/download/v${PV}/server-build-deps.tar.xz -> ${P}-server-build-deps.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ nvenc? (
+ x11-drivers/nvidia-drivers
+ )
+ vaapi? (
+ media-video/ffmpeg[libdrm,vaapi]
+ )
+ x264? (
+ media-libs/x264
+ )
+ dev-libs/libbsd
+ media-libs/libpulse
+ media-libs/openxr-loader
+ net-dns/avahi
+ systemd? (
+ sys-apps/systemd
+ )
+"
+
+BDEPEND="
+ ${RDEPEND}
+ nvenc? (
+ dev-util/nvidia-cuda-toolkit
+ )
+ dev-cpp/eigen
+ dev-cpp/nlohmann_json
+ dev-util/glslang
+"
+
+if [[ ${PV} == 9999 ]]; then
+ src_unpack() {
+ git-r3_src_unpack
+ default_src_unpack
+ cd "${WORKDIR}"
+ mv "monado-${MONADO_V}" "monado-src"
+ mv "pfr-${PFR_V}" "boostpfr-src"
+ }
+else
+ src_unpack() {
+ default_src_unpack
+ cd "${WORKDIR}"
+ mv "WiVRn-${PV}" "${P}"
+ }
+fi
+
+src_configure() {
+ if [[ ${PV} == 9999 ]]; then
+ GIT_DESC=$(git describe)
+ else
+ GIT_DESC=${PV}
+ fi
+ local mycmakeargs=(
+ -DGIT_DESC=${GIT_DESC}
+ -DWIVRN_BUILD_CLIENT=OFF
+ -DWIVRN_USE_NVENC=$(usex nvenc)
+ -DWIVRN_USE_VAAPI=$(usex vaapi)
+ -DWIVRN_USE_X264=$(usex x264)
+ -DWIVRN_USE_SYSTEMD=$(usex systemd)
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON
+ -DFETCHCONTENT_FULLY_DISCONNECTED=ON
+ -DFETCHCONTENT_BASE_DIR=${WORKDIR}
+ -DENABLE_COLOURED_OUTPUT=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dosym /usr/share/openxr/1/openxr_wivrn.json /etc/openxr/1/active_runtime.json
+}
diff --git a/media-libs/wivrn/wivrn-9999.ebuild b/media-libs/wivrn/wivrn-9999.ebuild
index fb978a9b4..a254c95c2 100644
--- a/media-libs/wivrn/wivrn-9999.ebuild
+++ b/media-libs/wivrn/wivrn-9999.ebuild
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Meumeu/WiVRn.git"
- MONADO_V=79bf8eb8fa168f65f4e5505e0525ee74aa88783e
+ MONADO_V=57e937383967c7e7b38b5de71297c8f537a2489d
PFR_V=2.0.3
SRC_URI="
https://github.com/boostorg/pfr/archive/refs/tags/${PFR_V}.tar.gz -> boostpfr_${PFR_V}.tar.gz
@@ -31,7 +31,7 @@ RDEPEND="
x11-drivers/nvidia-drivers
)
vaapi? (
- media-video/ffmpeg[libdrm,vulkan,vaapi]
+ media-video/ffmpeg[libdrm,vaapi]
)
x264? (
media-libs/x264