aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 20:11:26 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 20:32:02 +0200
commitb952f43f6f3806d5d807b57349304977be5c19d8 (patch)
treed1dcf9537c4511df7fe728b5e18a9b5aa2b27514
parentdev-python/types-paramiko: initial import (diff)
downloadguru-b952f43f.tar.gz
guru-b952f43f.tar.bz2
guru-b952f43f.zip
dev-python/os-win: new version
Closes: https://bugs.gentoo.org/799509 Closes: https://bugs.gentoo.org/799506 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/os-win/Manifest2
-rw-r--r--dev-python/os-win/os-win-5.1.0.ebuild34
-rw-r--r--dev-python/os-win/os-win-5.5.0.ebuild44
3 files changed, 45 insertions, 35 deletions
diff --git a/dev-python/os-win/Manifest b/dev-python/os-win/Manifest
index 2a0114cf5..086dce99c 100644
--- a/dev-python/os-win/Manifest
+++ b/dev-python/os-win/Manifest
@@ -1 +1 @@
-DIST os-win-5.1.0.tar.gz 221803 BLAKE2B 37fa5271b86f62a43ea1f6da011601260a9cd32745a2369093dc5103e54945c17d16ecfaf8f5d88fd7ec3673ac41e25ff02d3c15ec5423fb9651101213801cab SHA512 bb93af1b412b8e0699f62a772bf9bacc73e2e73751cf0e9b9a37d59869a6c31e39ddbaafc4b97b494d9a38208d765362a6ce7fe071e1c089c127e1554ae73a02
+DIST os-win-5.5.0.tar.gz 225851 BLAKE2B f0427ecfb25b45f4980992a54ae4b2d6518af5df17013dfd338c9331d1492cab36f9061082a41bee5ab829f31008ddaf7a8708fdd89d3df89d9989d30aba5357 SHA512 bc980d973f5089c1328095b6edfaabf2435df3acbca543a768dbbccc8a10ffce4405c54c7711d2c7fa55c40442fa4b116f2e2d40ad4116b1c8bb96ace3450335
diff --git a/dev-python/os-win/os-win-5.1.0.ebuild b/dev-python/os-win/os-win-5.1.0.ebuild
deleted file mode 100644
index 08f255276..000000000
--- a/dev-python/os-win/os-win-5.1.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
-HOMEPAGE="https://github.com/openstack/os-win"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
-RDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-"
diff --git a/dev-python/os-win/os-win-5.5.0.ebuild b/dev-python/os-win/os-win-5.5.0.ebuild
new file mode 100644
index 000000000..d24080f5f
--- /dev/null
+++ b/dev-python/os-win/os-win-5.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="
+ https://github.com/openstack/os-win
+ https://opendev.org/openstack/os-win
+ https://launchpad.net/os-win
+ https://pypi.org/project/os-win/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.29.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/hacking-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest