aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-02 22:00:56 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-02 22:01:15 +0200
commitb98c64e9f756d7e95130de35c66a3b861c35d6d8 (patch)
treec00649248a448c56eb2b52cd46e78bf6dce620db
parentdev-python/fastavro: add 1.4.11, drop 1.4.7 (diff)
downloadguru-b98c64e9.tar.gz
guru-b98c64e9.tar.bz2
guru-b98c64e9.zip
sci-mathematics/aspcud: add 1.9.6
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sci-mathematics/aspcud/Manifest1
-rw-r--r--sci-mathematics/aspcud/aspcud-1.9.6.ebuild52
-rw-r--r--sci-mathematics/aspcud/files/aspcud-1.9.6-system-catch.patch10
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-mathematics/aspcud/Manifest b/sci-mathematics/aspcud/Manifest
index 129f7b224..8804e929b 100644
--- a/sci-mathematics/aspcud/Manifest
+++ b/sci-mathematics/aspcud/Manifest
@@ -1 +1,2 @@
DIST aspcud-1.9.5.tar.gz 70073941 BLAKE2B e2f02259a726d05a664e63836ab24d798b3ef96276c92caf00907df5ea3d08b9d5e992c3ffb2f8ad95864e4251e2adde596d6327e71e7ae33fabd515eaeafb13 SHA512 b6c85f7e67cbf8df8dd0ed4f8fd5f988e46bf3f9756e4cb8fadfae955ed70bc27279e8dddcfe8161543e5276a70d2103816fce8edebc240fef6b182841832106
+DIST aspcud-1.9.6.tar.gz 70041232 BLAKE2B 9854185b9674a062ce017b1c210ca7fb3b802e564c46a2036d48bb3178c1d5c0158841ee9e1f4c0a33b30038c2d4477f307c14415df48cf50c37682ef292fce0 SHA512 a46183c2fd3b17881d48c3396164cded4b5214a2a8a31a499254533a8a71fb084a8b6f13ee1dc8eea72f7d9819caf2921f31a5ccc1cbd6611f9175e0bc10c14a
diff --git a/sci-mathematics/aspcud/aspcud-1.9.6.ebuild b/sci-mathematics/aspcud/aspcud-1.9.6.ebuild
new file mode 100644
index 000000000..0d38b0e6c
--- /dev/null
+++ b/sci-mathematics/aspcud/aspcud-1.9.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A solver for package problems in CUDF format"
+HOMEPAGE="
+ https://github.com/potassco/aspcud
+ https://potassco.org/aspcud/
+"
+SRC_URI="https://github.com/potassco/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-libs/boost:=
+ test? ( dev-cpp/catch:0 )
+"
+RDEPEND="
+ ${DEPEND}
+ sci-mathematics/clasp
+ sci-mathematics/clingo
+"
+BDEPEND="dev-util/re2c"
+
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-system-catch.patch" )
+
+src_prepare() {
+ rm libcudf/tests/catch.hpp || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DASPCUD_BUILD_TESTS=$(usex test)
+
+ -DASPCUD_BUILD_STATIC=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ insinto /usr/share/cudf/solvers/
+ doins "${FILESDIR}/aspcud"
+}
diff --git a/sci-mathematics/aspcud/files/aspcud-1.9.6-system-catch.patch b/sci-mathematics/aspcud/files/aspcud-1.9.6-system-catch.patch
new file mode 100644
index 000000000..b08c3100e
--- /dev/null
+++ b/sci-mathematics/aspcud/files/aspcud-1.9.6-system-catch.patch
@@ -0,0 +1,10 @@
+--- a/libcudf/tests/CMakeLists.txt
++++ b/libcudf/tests/CMakeLists.txt
+@@ -1,7 +1,6 @@
+ # [[[source: .
+ set(ide_source_group "Source Files")
+ set(source-group
+- "${CMAKE_CURRENT_SOURCE_DIR}/catch.hpp"
+ "${CMAKE_CURRENT_SOURCE_DIR}/criteria.cc"
+ "${CMAKE_CURRENT_SOURCE_DIR}/critparser.cc"
+ "${CMAKE_CURRENT_SOURCE_DIR}/helpers.hh"