aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 02:00:25 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 02:43:18 +0200
commitba9cbbe990b65710f80786222491155b6224f552 (patch)
treea863b3cb4df3c6b1d7a9c074b071f799991e2046
parentdev-python/pytest-cython: ebuild maintenance (diff)
downloadguru-ba9cbbe9.tar.gz
guru-ba9cbbe9.tar.bz2
guru-ba9cbbe9.zip
dev-python/pypandoc: bump
Closes: https://bugs.gentoo.org/800362 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pypandoc/Manifest2
-rw-r--r--dev-python/pypandoc/pypandoc-1.6.3.ebuild (renamed from dev-python/pypandoc/pypandoc-1.5.ebuild)16
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/pypandoc/Manifest b/dev-python/pypandoc/Manifest
index cc22e0eff..28d45ce9a 100644
--- a/dev-python/pypandoc/Manifest
+++ b/dev-python/pypandoc/Manifest
@@ -1 +1 @@
-DIST pypandoc-1.5.tar.gz 26494 BLAKE2B f265effc55db8b1f706a4541f18119de2d0cccc7ab59ea83f80e6051ae4a4e36128d6b36c51e255c2ed0b0577c1df46284820c97f629fc3b790c301448a6bb39 SHA512 511f5f5f7bff8de686c3f74d3756d27a3ae245803e2e9b45abc957acf112b306eff057ce87e8f3b335de00b97d4753de31e9681830d9aa776247ca707683ed13
+DIST pypandoc-1.6.3.tar.gz 25912 BLAKE2B 341055a519f943b8593720d2797bae2c6bb7b7c60dc73efdfecc432fcdbcb1e7b30af138e62512dfea1da0c24dcba5b387891e005b773cae6c9a008c188a99ff SHA512 74abcd569adfeebfd84e66c7b3e110fccd9200275ecfd32e78c297d4f18637c6dc3328c313c32c38b9b9504f64d24e6b59fdec505a539649a21d7e5434108c24
diff --git a/dev-python/pypandoc/pypandoc-1.5.ebuild b/dev-python/pypandoc/pypandoc-1.6.3.ebuild
index 1a04fc841..adcfbab97 100644
--- a/dev-python/pypandoc/pypandoc-1.5.ebuild
+++ b/dev-python/pypandoc/pypandoc-1.6.3.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -17,6 +18,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="test"
RDEPEND="
app-text/pandoc
@@ -30,11 +32,9 @@ DEPEND="
dev-python/urllib3[${PYTHON_USEDEP}]
"
-python_test() {
- # Skip tests. Wants: internet access
- sed -i -e 's:test_basic_conversion_from_http_url:_&:' tests.py || die
- # Skip tests. Wants: nonexistent font
- sed -i -e 's:test_pdf_conversion:_&:' tests.py || die
+PROPERTIES="test_network"
+RESTRICT="test"
+python_test() {
"${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
}