aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-07 12:44:49 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-07 12:47:50 +0200
commitbc0713ed1c017d0fd46ee9ae30a755c0852e65db (patch)
tree4849bcfec9064c21b17891579488fa7036b32be7
parentsys-cluster/nanos6: rename babeltrace to ctf2prv (diff)
downloadguru-bc0713ed1c017d0fd46ee9ae30a755c0852e65db.tar.gz
guru-bc0713ed1c017d0fd46ee9ae30a755c0852e65db.tar.bz2
guru-bc0713ed1c017d0fd46ee9ae30a755c0852e65db.zip
sci-libs/dart: respect LDFLAGS
Closes: https://bugs.gentoo.org/791418 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sci-libs/dart/dart-6.10.1-r2.ebuild13
-rw-r--r--sci-libs/dart/files/dart-respect-ldflags.patch11
-rw-r--r--sci-libs/dart/metadata.xml1
3 files changed, 19 insertions, 6 deletions
diff --git a/sci-libs/dart/dart-6.10.1-r2.ebuild b/sci-libs/dart/dart-6.10.1-r2.ebuild
index a0947f03b..d475a1738 100644
--- a/sci-libs/dart/dart-6.10.1-r2.ebuild
+++ b/sci-libs/dart/dart-6.10.1-r2.ebuild
@@ -14,10 +14,12 @@ SRC_URI="https://github.com/dartsim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="bullet doc examples extras glut +ipopt +nlopt ode openscenegraph python test tutorials urdfdom"
+IUSE="bullet doc examples extras glut +ipopt +nlopt ode openscenegraph python test tests tutorials urdfdom"
#TODO: pagmo
+#TODO: unbundle imgui
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${PN}-respect-ldflags.patch" )
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
@@ -28,7 +30,6 @@ RDEPEND="
app-arch/lz4
>=dev-cpp/eigen-3.0.5
dev-libs/boost
- dev-libs/tinyxml
dev-libs/tinyxml2
>=sci-libs/libccd-2.0
>=media-libs/assimp-3.0.0
@@ -76,10 +77,10 @@ src_configure() {
src_compile() {
cmake_src_compile
- use examples && cmake_src_compile examples
-# use python && cmake_src_compile dartpy
-# use test && cmake_src_compile tests
-# use tutorials && cmake_src_compile tutorials
+ use examples && cmake_build examples
+ use python && cmake_build dartpy # no work to do ...
+ use test && cmake_build tests
+ use tutorials && cmake_build tutorials
}
src_install() {
diff --git a/sci-libs/dart/files/dart-respect-ldflags.patch b/sci-libs/dart/files/dart-respect-ldflags.patch
new file mode 100644
index 000000000..0fa4397cd
--- /dev/null
+++ b/sci-libs/dart/files/dart-respect-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -220,7 +220,7 @@
+ endif()
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELEASE} ${CMAKE_CXX_FLAGS_DEBUG}")
+ set(CMAKE_CXX_FLAGS_PROFILE "${CMAKE_CXX_FLAGS_DEBUG} -pg")
+- set(CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined")
++ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined")
+
+ # Enforce to colorize compilation output
+ if(${DART_FORCE_COLORED_OUTPUT})
diff --git a/sci-libs/dart/metadata.xml b/sci-libs/dart/metadata.xml
index 98e526744..486eef082 100644
--- a/sci-libs/dart/metadata.xml
+++ b/sci-libs/dart/metadata.xml
@@ -17,6 +17,7 @@
<flag name="nlopt">NLopt Optimization Support</flag>
<flag name="ode">ODE Collision Detector Support</flag>
<flag name="openscenegraph">OpenSceneGraph GUI and examples</flag>
+ <flag name="tests">Build the tests</flag>
<flag name="tutorials">Build the tutorials</flag>
<flag name="urdfdom">URDF parser</flag>
</use>