aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-29 14:42:47 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-29 15:08:27 +0200
commitbc43993963b7a31da702454e5a7afccd532ba94d (patch)
treec34989a5439a07cd2018f5ae2c8d5479e6d9a55e
parentnet-p2p/bisq: update (diff)
downloadguru-bc43993963b7a31da702454e5a7afccd532ba94d.tar.gz
guru-bc43993963b7a31da702454e5a7afccd532ba94d.tar.bz2
guru-bc43993963b7a31da702454e5a7afccd532ba94d.zip
dev-python/oslo-rootwrap: new version
Closes: https://bugs.gentoo.org/800332 Closes: https://bugs.gentoo.org/800329 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/oslo-rootwrap/Manifest2
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild22
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-6.3.0.ebuild39
3 files changed, 40 insertions, 23 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index a175dc28a..f0b0fd786 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -1 +1 @@
-DIST oslo.rootwrap-6.2.0.tar.gz 46850 BLAKE2B 0ad998aecaf8dfe0616094ed08e64380d38fa663dc63f192b58b95a07deeb690f16f1b8de2d0666c80bc49c11c06dc7221e9b9fae7243c3569971745884b752f SHA512 bf3e91ec8a18f92f6f5974a6d8369ae73dba6e61fa3001996678b85d0bfb2426536d27097ad784169e6eca50ad23471505d5089e8d4a6a84c9e0e009a6a38f5a
+DIST oslo.rootwrap-6.3.0.tar.gz 49527 BLAKE2B 8e3489674d4aca6eba36973457d14158ac1846e69a4ce102a16af1aafe5a36b8503119c3ab2bb576d493eb0222ba63a021e9a89b7ff621db94ebff990a3d504e SHA512 0f22e3b3b23dbad18109b3f11c18c2e278d582afc62bd03909e46445231e905a70b26a38773ab9c5543a0bcd0987f0681dfaf5a633cbf24f0144c6ff1f081626
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild
deleted file mode 100644
index 7af57ea20..000000000
--- a/dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.rootwrap/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
-S="${WORKDIR}/oslo.rootwrap-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-DEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
-RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-6.3.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-6.3.0.ebuild
new file mode 100644
index 000000000..a7a9e438a
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-6.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="
+ https://pypi.org/project/oslo.rootwrap
+ https://opendev.org/openstack/oslo.rootwrap
+ https://launchpad.net/oslo.rootwrap
+"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.2[${PYTHON_USEDEP}]
+ >=dev-python/reno-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest