aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-11 17:33:06 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-11 17:33:06 +0200
commitbc783bcc379c20d3bf645e9fde126d75754a1af8 (patch)
treeffb25df371f08cd8462d9dd545df01af16ddc439
parentdev-R/RcppEnsmallen: add 0.2.15.0.1, drop 0.2.16.1.1 (diff)
downloadguru-bc783bcc.tar.gz
guru-bc783bcc.tar.bz2
guru-bc783bcc.zip
sci-libs/ensmallen: import from ::science
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sci-libs/ensmallen/Manifest5
-rw-r--r--sci-libs/ensmallen/ensmallen-2.14.2.ebuild28
-rw-r--r--sci-libs/ensmallen/ensmallen-2.15.0.ebuild28
-rw-r--r--sci-libs/ensmallen/ensmallen-2.15.1.ebuild28
-rw-r--r--sci-libs/ensmallen/ensmallen-2.16.0.ebuild28
-rw-r--r--sci-libs/ensmallen/ensmallen-2.16.2.ebuild28
-rw-r--r--sci-libs/ensmallen/metadata.xml8
7 files changed, 153 insertions, 0 deletions
diff --git a/sci-libs/ensmallen/Manifest b/sci-libs/ensmallen/Manifest
new file mode 100644
index 0000000000..d74da89b97
--- /dev/null
+++ b/sci-libs/ensmallen/Manifest
@@ -0,0 +1,5 @@
+DIST ensmallen-2.14.2.tar.gz 1262697 BLAKE2B c3ecd10271a476cdb03de0a74dd1e7d250273481b540d9cadb44ff7292cdb1f4abbefaf7c1a90bd33c68928f766db8afafd45f253735a36de9def6ab222597bb SHA512 9f29d70f66748d6131b44fc2a580e9fc07131a3aeecaa9f6113fd635eaff8b52db90e487a389393a1976dcccb8c1f5850ea50e03308af90b58ba1c12fde2bd21
+DIST ensmallen-2.15.0.tar.gz 1266409 BLAKE2B 379ea897d3b29440e89d65cb60c65dca3c34a530dd8a4cee321349d177455b020d4aa19ee1e701b46a325a8f56028c236ab80b0383bee84018952034106f7161 SHA512 7e8ea0d64788287e58ee14e922c81c18e1804a23dba3d144fe6e66de8a81dfd3755c9f36a1e8a480aa6e15f0f7b1ff886e0aeecde0be35993db0ba69ca7e12e0
+DIST ensmallen-2.15.1.tar.gz 1266496 BLAKE2B 7ff803207c59be03fa47e7fddafb49176d307fbea89f5688bd591898fb36d7d8ee018dec933b59a06063dc6c2a7117d3ec0d330cd37d475e4f387528f2d86f6a SHA512 4f0cda1ad0d02e823042fb6af03635677e3d5cac28f7f13fab20fc7f4b3d7fbe1b182777c573187a403eff5e5fd7e1e577e290a4b624a9c2a71cbfd347e14afa
+DIST ensmallen-2.16.0.tar.gz 1264948 BLAKE2B a58de7e7d8aa88988b08d76c2a5746daf9074ccc39bc8df9d21b61d745741d6521922b578e01b60e0d1657f84f377f411172a01d50bbcd30cca7142da0baeb7b SHA512 39afc19936710d5595218292f5d6a055b4f644ca157f9fc2329fb18b71318b9f613dc26169921e1fda3dd949d06847dee4f09f13c1902a92e38826e122c1adc5
+DIST ensmallen-2.16.2.tar.gz 1294240 BLAKE2B b388f2c99f289dd20f6d94b5b185d872abc553637c6081ea3a80a3c82ce9ac8b1327496bf3eae6dc5cbf5f4ae12a9fd1e8ccf9c296007f9af9cbfc7560cd0301 SHA512 290932f8e423be7c57d8ba38783a29798df52a7505ded7683f969fa30391398edcca584daca1b1c42977f06180a802d4c3640a9ec24cd787a3914723e4eb6f8d
diff --git a/sci-libs/ensmallen/ensmallen-2.14.2.ebuild b/sci-libs/ensmallen/ensmallen-2.14.2.ebuild
new file mode 100644
index 0000000000..bd1c0530b9
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.14.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/ensmallen/ensmallen-2.15.0.ebuild b/sci-libs/ensmallen/ensmallen-2.15.0.ebuild
new file mode 100644
index 0000000000..bd1c0530b9
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.15.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/ensmallen/ensmallen-2.15.1.ebuild b/sci-libs/ensmallen/ensmallen-2.15.1.ebuild
new file mode 100644
index 0000000000..bd1c0530b9
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.15.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/ensmallen/ensmallen-2.16.0.ebuild b/sci-libs/ensmallen/ensmallen-2.16.0.ebuild
new file mode 100644
index 0000000000..bd1c0530b9
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/ensmallen/ensmallen-2.16.2.ebuild b/sci-libs/ensmallen/ensmallen-2.16.2.ebuild
new file mode 100644
index 0000000000..bd1c0530b9
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.16.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/ensmallen/metadata.xml b/sci-libs/ensmallen/metadata.xml
new file mode 100644
index 0000000000..e15add1ea3
--- /dev/null
+++ b/sci-libs/ensmallen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- Maintainer Needed -->
+ <upstream>
+ <remote-id type="github">mlpack/ensmallen</remote-id>
+ </upstream>
+</pkgmetadata>