aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-28 17:50:31 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-28 17:50:31 +0200
commitbea0ab948cce6bce92628a2f04b703d94bd65fd7 (patch)
tree11abe682c37a19e8052da491d1e65a66d0f899b8
parentdev-R/ps: add 1.7.1, drop 1.7.0 (diff)
downloadguru-bea0ab94.tar.gz
guru-bea0ab94.tar.bz2
guru-bea0ab94.zip
dev-cpp/parallel-hashmap: add 1.35, drop 1.33
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-cpp/parallel-hashmap/Manifest2
-rw-r--r--dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild (renamed from dev-cpp/parallel-hashmap/parallel-hashmap-1.33.ebuild)23
2 files changed, 15 insertions, 10 deletions
diff --git a/dev-cpp/parallel-hashmap/Manifest b/dev-cpp/parallel-hashmap/Manifest
index 198c39302..d80bc3e49 100644
--- a/dev-cpp/parallel-hashmap/Manifest
+++ b/dev-cpp/parallel-hashmap/Manifest
@@ -1,2 +1,2 @@
-DIST parallel-hashmap-1.33.tar.gz 2038996 BLAKE2B b704a0230bd6d15e8a3a1aa11bec456183119d5104e1ac191e556edae1c0b0d2a27c5b52c84cae167cd09a90f4fc43f817c21d64d6b288a70596b6495ee872e6 SHA512 287f098229153d925632e68e3cdbabfae0ea0ab8864089e4c0553a166c6079ca82ed5246ba53afd2a2917abcf06f37bc18f098e721f5f3b8def4d2d8c1c8c745
DIST parallel-hashmap-1.34.tar.gz 2043028 BLAKE2B 30629288656a22cfd56da9485458f604487383cc5951e230a833b182cbbcc706b78d0b8a45fb76c4fca6da930f49cdb79b2ca63926ca8cd60cc7445b58c8edbd SHA512 3747422e80406aa77b009adee3c16325640dd1044560882fb881dac5ef4109f7d165d26ed7e64002c9285275f95962725ce20c918da12c0c113999c8ca3c7429
+DIST parallel-hashmap-1.35.gh.tar.gz 2044770 BLAKE2B 18c4843ebd2ca046e1597a7fc0341440d888c4b39d2355e45b36e02b9f5dcf39baec1826434d70b591e6713fe2ff043a9ec8a68b7b43e0fbb2af176507b738ba SHA512 ffa70a6691784caa8acc6e191b3db4ffdbbc51db86c91118267fac96c178d434f890f773c9b31932eaed15b2cecbd74dcaddacefd0ef9771da0833c90d0f104c
diff --git a/dev-cpp/parallel-hashmap/parallel-hashmap-1.33.ebuild b/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
index e2824c2e1..036b306d5 100644
--- a/dev-cpp/parallel-hashmap/parallel-hashmap-1.33.ebuild
+++ b/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -10,20 +10,25 @@ HOMEPAGE="
https://greg7mdp.github.io/parallel-hashmap/
https://github.com/greg7mdp/parallel-hashmap
"
-SRC_URI="https://github.com/greg7mdp/parallel-hashmap/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/greg7mdp/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="Apache-2.0"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64"
-IUSE="examples"
+IUSE="examples test"
-DEPEND=""
-RDEPEND="${DEPEND}"
+CDEPEND="dev-libs/cereal"
+DEPEND="test? ( ${CDEPEND} )"
+RDEPEND="${CDEPEND}"
-#TODO: explore the various cmake options (if any)
-#TODO: tests
+RESTRICT="!test? ( test )"
src_compile() {
+ mycmakeargs=(
+ PHMAP_BUILD_EXAMPLES=$(usex examples)
+ PHMAP_BUILD_TESTS=$(usex test)
+ )
+
cmake_src_compile
}