aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-16 18:38:11 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-16 20:27:38 +0200
commitbff089337c583b35ff10e91d7bdbc630e1fe95bc (patch)
tree4cecf5c96bce3a51b90270a42c06406dd51a9db9
parentdev-ml/cstruct: update HOMEPAGE (diff)
downloadguru-bff08933.tar.gz
guru-bff08933.tar.bz2
guru-bff08933.zip
dev-ml/ipaddr: update HOMEPAGE
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-ml/ipaddr/files/ipaddr-5.3.0-ounit2.patch129
-rw-r--r--dev-ml/ipaddr/ipaddr-5.3.0.ebuild24
2 files changed, 143 insertions, 10 deletions
diff --git a/dev-ml/ipaddr/files/ipaddr-5.3.0-ounit2.patch b/dev-ml/ipaddr/files/ipaddr-5.3.0-ounit2.patch
new file mode 100644
index 0000000000..d2d1ec5829
--- /dev/null
+++ b/dev-ml/ipaddr/files/ipaddr-5.3.0-ounit2.patch
@@ -0,0 +1,129 @@
+From c0352e7e1c2fdbc22e06dedb839831f5694d7429 Mon Sep 17 00:00:00 2001
+From: Alessandro-Barbieri <lssndrbarbieri@gmail.com>
+Date: Sat, 16 Apr 2022 18:36:24 +0200
+Subject: [PATCH] switch to ounit2
+
+Signed-off-by: Alessandro-Barbieri <lssndrbarbieri@gmail.com>
+---
+ README.md | 2 +-
+ ipaddr-sexp.opam | 2 +-
+ ipaddr.opam | 4 ++--
+ lib_test/dune | 8 ++++----
+ macaddr-sexp.opam | 2 +-
+ macaddr.opam | 4 ++--
+ 6 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/README.md b/README.md
+index 6e1ec56..4aace13 100644
+--- a/README.md
++++ b/README.md
+@@ -4,7 +4,7 @@ A library for manipulation of IP and MAC address representations.
+
+ Features:
+
+- * oUnit-based tests
++ * ounit2-based tests
+ * IPv4 and IPv6 support
+ * IPv4 and IPv6 CIDR prefix support
+ * IPv4 and IPv6 [CIDR-scoped address](http://tools.ietf.org/html/rfc4291#section-2.3) support
+diff --git a/ipaddr-sexp.opam b/ipaddr-sexp.opam
+index 735ad08..4f4be93 100644
+--- a/ipaddr-sexp.opam
++++ b/ipaddr-sexp.opam
+@@ -16,7 +16,7 @@ depends: [
+ "dune" {>= "1.9.0"}
+ "ipaddr" {= version}
+ "ipaddr-cstruct" {with-test & = version}
+- "ounit" {with-test}
++ "ounit2" {with-test}
+ "ppx_sexp_conv" {>= "v0.9.0"}
+ "sexplib0"
+ ]
+diff --git a/ipaddr.opam b/ipaddr.opam
+index 240d9c8..02f5570 100644
+--- a/ipaddr.opam
++++ b/ipaddr.opam
+@@ -5,7 +5,7 @@ synopsis: "A library for manipulation of IP (and MAC) address representations"
+ description: """
+ Features:
+ * Depends only on sexplib (conditionalization under consideration)
+- * oUnit-based tests
++ * ounit2-based tests
+ * IPv4 and IPv6 support
+ * IPv4 and IPv6 CIDR prefix support
+ * IPv4 and IPv6 [CIDR-scoped address](http://tools.ietf.org/html/rfc4291#section-2.3) support
+@@ -32,7 +32,7 @@ depends: [
+ "macaddr" {= version}
+ "stdlib-shims"
+ "domain-name" {>= "0.3.0"}
+- "ounit" {with-test}
++ "ounit2" {with-test}
+ "ppx_sexp_conv" {with-test & >= "v0.9.0"}
+ ]
+ build: [
+diff --git a/lib_test/dune b/lib_test/dune
+index 8dd7d27..fc6f285 100644
+--- a/lib_test/dune
++++ b/lib_test/dune
+@@ -27,22 +27,22 @@
+ (name test_ipaddr)
+ (package ipaddr-sexp)
+ (modules test_ipaddr)
+- (libraries ipaddr ipaddr-cstruct test_ipaddr_sexp oUnit))
++ (libraries ipaddr ipaddr-cstruct test_ipaddr_sexp ounit2))
+
+ (test
+ (name test_ipaddr_b128)
+ (package ipaddr-sexp)
+ (modules test_ipaddr_b128 ipaddr_internal)
+- (libraries ipaddr ipaddr-cstruct test_ipaddr_sexp oUnit))
++ (libraries ipaddr ipaddr-cstruct test_ipaddr_sexp ounit2))
+
+ (test
+ (name test_macaddr)
+ (package macaddr-sexp)
+ (modules test_macaddr)
+- (libraries macaddr macaddr-cstruct test_macaddr_sexp oUnit))
++ (libraries macaddr macaddr-cstruct test_macaddr_sexp ounit2))
+
+ (test
+ (name test_ppx)
+ (modules test_ppx)
+ (package ipaddr-sexp)
+- (libraries ipaddr macaddr test_ipaddr_sexp test_macaddr_sexp oUnit))
++ (libraries ipaddr macaddr test_ipaddr_sexp test_macaddr_sexp ounit2))
+diff --git a/macaddr-sexp.opam b/macaddr-sexp.opam
+index 26e6fcf..e7773fe 100644
+--- a/macaddr-sexp.opam
++++ b/macaddr-sexp.opam
+@@ -12,7 +12,7 @@ depends: [
+ "dune" {>= "1.9.0"}
+ "macaddr" {= version}
+ "macaddr-cstruct" {with-test & = version}
+- "ounit" {with-test}
++ "ounit2" {with-test}
+ "ppx_sexp_conv" {>= "v0.9.0"}
+ "sexplib0"
+ ]
+diff --git a/macaddr.opam b/macaddr.opam
+index 13fcf31..6e2106f 100644
+--- a/macaddr.opam
++++ b/macaddr.opam
+@@ -10,7 +10,7 @@ bug-reports: "https://github.com/mirage/ocaml-ipaddr/issues"
+ depends: [
+ "ocaml" {>= "4.04.0"}
+ "dune" {>= "1.9.0"}
+- "ounit" {with-test}
++ "ounit2" {with-test}
+ "ppx_sexp_conv" {with-test & >= "v0.9.0"}
+ ]
+ conflicts: [ "ipaddr" {< "3.0.0"} ]
+@@ -25,7 +25,7 @@ A library for manipulation of MAC address representations.
+
+ Features:
+
+- * oUnit-based tests
++ * ounit2-based tests
+ * MAC-48 (Ethernet) address support
+ * `Macaddr` is a `Map.OrderedType`
+ * All types have sexplib serializers/deserializers optionally via the `Macaddr_sexp` library.
diff --git a/dev-ml/ipaddr/ipaddr-5.3.0.ebuild b/dev-ml/ipaddr/ipaddr-5.3.0.ebuild
index 3cd8e9e431..7a9bdd812e 100644
--- a/dev-ml/ipaddr/ipaddr-5.3.0.ebuild
+++ b/dev-ml/ipaddr/ipaddr-5.3.0.ebuild
@@ -6,7 +6,10 @@ EAPI=8
inherit dune multiprocessing
DESCRIPTION="OCaml library for manipulation of IP (and MAC) address representations"
-HOMEPAGE="https://github.com/mirage/ocaml-ipaddr"
+HOMEPAGE="
+ https://github.com/mirage/ocaml-ipaddr
+ https://opam.ocaml.org/packages/ipaddr/
+"
SRC_URI="https://github.com/mirage/ocaml-ipaddr/archive/v${PV}.tar.gz -> ocaml-${P}.tar.gz"
S="${WORKDIR}/ocaml-${P}"
@@ -16,30 +19,31 @@ KEYWORDS="~amd64"
IUSE="cstruct macaddr-cstruct macaddr-sexp ocamlopt sexp test"
RDEPEND="
- dev-ml/domain-name
- dev-ml/stdlib-shims
+ dev-ml/domain-name:=
+ dev-ml/stdlib-shims:=
- cstruct? ( dev-ml/cstruct )
- macaddr-cstruct? ( dev-ml/cstruct )
+ cstruct? ( dev-ml/cstruct:= )
+ macaddr-cstruct? ( dev-ml/cstruct:= )
macaddr-sexp? (
- dev-ml/ppx_sexp_conv
- dev-ml/sexplib0
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/sexplib0:=
)
sexp? (
- dev-ml/ppx_sexp_conv
- dev-ml/sexplib0
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/sexplib0:=
)
"
DEPEND="
${RDEPEND}
test? (
- dev-ml/ounit
+ dev-ml/ounit2
dev-ml/ppx_sexp_conv
)
"
RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( cstruct macaddr-cstruct macaddr-sexp sexp )"
+PATCHES="${FILESDIR}/${P}-ounit2.patch"
src_compile() {
local pkgs="ipaddr,macaddr"