aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-28 01:11:04 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-28 01:11:04 +0200
commitc10554072d604ad0cde34ebd7112152ac923b471 (patch)
treec07ada30069dce33ea4226d13c6697a67dfc1ecd
parentdev-python/cattrs: add 1.7.0 (diff)
downloadguru-c1055407.tar.gz
guru-c1055407.tar.bz2
guru-c1055407.zip
dev-python/asyncssh: add 2.7.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/asyncssh/Manifest1
-rw-r--r--dev-python/asyncssh/asyncssh-2.7.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/asyncssh/Manifest b/dev-python/asyncssh/Manifest
index d9511fd47..88408ea69 100644
--- a/dev-python/asyncssh/Manifest
+++ b/dev-python/asyncssh/Manifest
@@ -1 +1,2 @@
DIST asyncssh-2.6.0.tar.gz 419074 BLAKE2B ecac549c3b95b024cf6135e8809720f547607842506e874fd066c351fd89d48b705c4056efdfebed4e88e74f544e8d362d95690c9574e5cd4e0de5cafd84b44e SHA512 b1421ba03bbc3f919ebdc3f4936e024ecb579e9a6823ff507be5fb3b6e03ff0b7aaebf364282902b53f82eeaa095894d747e200eb9fc28cad19d94ec809448a3
+DIST asyncssh-2.7.0.tar.gz 420765 BLAKE2B 4beab38843951cb9e86f5dc88b4bde4efd9a29178160381ea359233b675d2fa8bbfe58750b8d3fdded65998ea3c472b7b26c07fa191bd8428a06e3e014794dfe SHA512 0f25b199075fc5ff2f27c040b81d679c17fdebb68e919abc23af5b10dc0626eb10141bd6d6de7d92f797f84394a54c34757a8332c4aa08bab36ec6f04e353204
diff --git a/dev-python/asyncssh/asyncssh-2.7.0.ebuild b/dev-python/asyncssh/asyncssh-2.7.0.ebuild
new file mode 100644
index 000000000..fb28de3c9
--- /dev/null
+++ b/dev-python/asyncssh/asyncssh-2.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCS_BUILDER="sphinx"
+DOCS_DIR="docs"
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1 docs optfeature
+
+DESCRIPTION="Asynchronous SSHv2 client and server library"
+HOMEPAGE="
+ https://asyncssh.timeheart.net
+ https://pypi.org/project/asyncssh
+ https://github.com/ronf/asyncssh
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ECL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/cryptography-2.8[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${REDEPEND}
+ test? (
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/gssapi-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/libnacl-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-pkcs11-0.7.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+#python_test() {
+# epytest \
+# --deselect tests/test_agent.py::_TestAgent::test_confirm \
+# --deselect tests/test_x509.py::_TestX509::test_expired_root
+#}
+
+pkg_postinst() {
+ optfeature "support for OpenSSH private key encryption" dev-python/bcrypt
+ optfeature "support for key exchange and authentication with U2F/FIDO2 security keys" dev-python/fido2
+ optfeature "support for accessing PIV keys on PKCS#11 security tokens" dev-python/python-pkcs11
+ optfeature "support for GSSAPI key exchange and authentication on UNIX" dev-python/gssapi
+ optfeature "if you have a version of OpenSSL older than 1.1.1b installed and you want support for Curve25519 key exchange, Ed25519 keys and certificates, or the Chacha20-Poly1305 cipher" dev-python/libnacl
+ optfeature "support for UMAC cryptographic hashes" dev-python/libnettle
+ optfeature "support for X.509 certificate authentication" dev-python/pyopenssl
+}