aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2023-09-07 00:02:23 +0200
committerHenri Gasc <gasc@eurecom.fr>2023-09-07 00:02:23 +0200
commitc208f617545bb6c49e973d541fbfa4f066ddf9d0 (patch)
tree4393ab12f2c405101dc085b458de7e29b04b080b
parentdev-python/textual-dev: new package, add 1.1.0 (diff)
downloadguru-c208f617545bb6c49e973d541fbfa4f066ddf9d0.tar.gz
guru-c208f617545bb6c49e973d541fbfa4f066ddf9d0.tar.bz2
guru-c208f617545bb6c49e973d541fbfa4f066ddf9d0.zip
dev-python/textual: drop 0.14.0, add 0.36.0
Signed-off-by: Henri Gasc <gasc@eurecom.fr>
-rw-r--r--dev-python/textual/Manifest2
-rw-r--r--dev-python/textual/metadata.xml1
-rw-r--r--dev-python/textual/textual-0.14.0.ebuild82
-rw-r--r--dev-python/textual/textual-0.36.0.ebuild48
4 files changed, 50 insertions, 83 deletions
diff --git a/dev-python/textual/Manifest b/dev-python/textual/Manifest
index bdae15212..d7be15c01 100644
--- a/dev-python/textual/Manifest
+++ b/dev-python/textual/Manifest
@@ -1 +1 @@
-DIST textual-0.14.0.gh.tar.gz 25273607 BLAKE2B 9ce16bcb6e4fc5e3dea432f7a15086f5edef1740d9a0f55f6eeabf373fd7e64d0a3b06c277d1e61020def66b2d1d7d2b8f095747583b3a80da06c1103b198fe1 SHA512 1830546f8b07078f94525127f6a99771e54e29a9c4a217fda59f9b9de0fc85e893014af0d1a0b79fab4c237a76114516513662f67ce0203e72d2cba7f4f1bec7
+DIST textual-0.36.0.gh.tar.gz 25861324 BLAKE2B fa4b31b743452e583e40f95a86bb9b0e05a984a04aa83b4820eeed0124bebdb88e011f7d4cfd362cd686bab2df85913a2f4642218b25da9521c871926bbfe46b SHA512 506f04a4eaa363e4423a823b8f4c804d2a531dd246905cf48d0cb001b59f1e1e936bd7b755424d69e5037f4d631fe6c8ea8799cb2d60c4a3fcf2982625d0cc86
diff --git a/dev-python/textual/metadata.xml b/dev-python/textual/metadata.xml
index 5e66dc860..35709d6f1 100644
--- a/dev-python/textual/metadata.xml
+++ b/dev-python/textual/metadata.xml
@@ -8,5 +8,6 @@
<upstream>
<remote-id type="pypi">textual</remote-id>
<remote-id type="github">Textualize/textual</remote-id>
+ <doc>https://textual.textualize.io/</doc>
</upstream>
</pkgmetadata>
diff --git a/dev-python/textual/textual-0.14.0.ebuild b/dev-python/textual/textual-0.14.0.ebuild
deleted file mode 100644
index ae054bf68..000000000
--- a/dev-python/textual/textual-0.14.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Modern Text User Interface framework"
-HOMEPAGE="https://github.com/Textualize/textual https://pypi.org/project/textual"
-SRC_URI="https://github.com/Textualize/textual/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-# KEYWORDS="~amd64" # If set, can not commit because of dev-python/py-nanoid and dev-python/mkdocs-blog-plugin
-IUSE="doc"
-
-RDEPEND="
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/pytest-syrupy[${PYTHON_USEDEP}]
- dev-python/py-nanoid[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/time-machine[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/mkdocs[${PYTHON_USEDEP}]
- dev-python/mkdocs-exclude[${PYTHON_USEDEP}]
- dev-python/mkdocs-mkdocstrings[${PYTHON_USEDEP}]
- dev-python/mkdocs-mkdocstrings-python[${PYTHON_USEDEP}]
- dev-python/mkdocs-material[${PYTHON_USEDEP}]
- dev-python/mkdocs-material-extensions[${PYTHON_USEDEP}]
- dev-python/mkdocs-blog-plugin[${PYTHON_USEDEP}]
- dev-python/mkdocs-rss-plugin[${PYTHON_USEDEP}]
- dev-python/mkdocs-autorefs[${PYTHON_USEDEP}]
- dev-python/py-nanoid[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- ${BDEPEND}
- ${RDEPEND}
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # MkDocs need git repo
- if use doc; then
- git init -b temp || die
- git config user.email "you@example.com" || die
- git config user.name "Your Name" || die
- git add . || die
- git commit -m 'init' -q || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- if use doc; then
- mkdocs build --config-file mkdocs-common.yml
- einstalldocs site
- fi
- distutils-r1_python_install
-}
-
-python_test() {
- # Those tests ask to press keys
- local EPYTEST_IGNORE="tests/snapshot_tests/test_snapshots.py"
- epytest "${S}/tests" || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/textual/textual-0.36.0.ebuild b/dev-python/textual/textual-0.36.0.ebuild
new file mode 100644
index 000000000..7b1d86b02
--- /dev/null
+++ b/dev-python/textual/textual-0.36.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Modern Text User Interface framework"
+HOMEPAGE="https://github.com/Textualize/textual https://pypi.org/project/textual/"
+SRC_URI="https://github.com/Textualize/textual/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/importlib-metadata-4.11.3[${PYTHON_USEDEP}]
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.3.3[${PYTHON_USEDEP}]
+ =dev-python/typing-extensions-4*[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.3.3[${PYTHON_USEDEP}]
+ =dev-python/typing-extensions-4*[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/textual-dev[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ elog "If you want the documentation, you can read it at https://textual.textualize.io/"
+}
+
+python_test() {
+ # Those tests ask to press keys
+ local EPYTEST_IGNORE="tests/snapshot_tests/test_snapshots.py"
+ epytest "${S}/tests" || die "Tests failed with ${EPYTHON}"
+}