aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Athalye <andrewathalye@outlook.com>2021-11-04 14:51:38 +0000
committerAndrew Athalye <andrewathalye@outlook.com>2021-11-04 14:51:38 +0000
commitc351794e437b8d100cf9d43372cab7aa5b340097 (patch)
tree318a40d1ab1202a9202887bd8c693b989e14f03c
parentmedia-plugins/qt-jpegxl-image-plugin: require libjxl 0.6.1 (diff)
downloadguru-c351794e.tar.gz
guru-c351794e.tar.bz2
guru-c351794e.zip
net-misc/moonlight: Introduced package.
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Athalye <andrewathalye@outlook.com>
-rw-r--r--net-misc/moonlight/Manifest1
-rw-r--r--net-misc/moonlight/metadata.xml13
-rw-r--r--net-misc/moonlight/moonlight-3.1.4.ebuild58
3 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/moonlight/Manifest b/net-misc/moonlight/Manifest
new file mode 100644
index 000000000..df8201035
--- /dev/null
+++ b/net-misc/moonlight/Manifest
@@ -0,0 +1 @@
+DIST MoonlightSrc-3.1.4.tar.gz 55034473 BLAKE2B 1e420ea2f711f010f37e98ae2807ef7b449547d162065ea00809a07174d9e70ce78c7a2dc627ea8f2c275048277f8d45e7430c52df8b8b757c13646e831bbb2e SHA512 893b73f00fb8552f6a7c7bc8dbacac10e7280f2bb31a4813321e3c62a8071b8c6e87688ff9d60bfb27556dea6873c0a87a822e25b6cc0529f016bce7f3480ebc
diff --git a/net-misc/moonlight/metadata.xml b/net-misc/moonlight/metadata.xml
new file mode 100644
index 000000000..6e39cab3f
--- /dev/null
+++ b/net-misc/moonlight/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewathalye@outlook.com</email>
+ <description>Andrew Athalye</description>
+ </maintainer>
+ <use>
+ <flag name="vaapi">
+ Enable support for hardware video decoding using <pkg>x11-libs/libva</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/moonlight/moonlight-3.1.4.ebuild b/net-misc/moonlight/moonlight-3.1.4.ebuild
new file mode 100644
index 000000000..c8c06d392
--- /dev/null
+++ b/net-misc/moonlight/moonlight-3.1.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit qmake-utils
+inherit xdg-utils
+
+DESCRIPTION="GameStream client for PCs"
+
+HOMEPAGE="https://github.com/moonlight-stream/moonlight-qt"
+
+SRC_URI="https://github.com/moonlight-stream/moonlight-qt/releases/download/v3.1.4/MoonlightSrc-3.1.4.tar.gz"
+
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# Comprehensive list of any and all USE flags leveraged in the ebuild,
+# with some exceptions, e.g., ARCH specific flags like "amd64" or "ppc".
+# Not needed if the ebuild doesn't use any USE flags.
+IUSE="vaapi"
+
+RDEPEND="
+ >=dev-libs/openssl-1.1.1l:0/1.1
+ >=media-libs/libsdl2-2.0.16-r1:0
+ >=media-libs/sdl2-ttf-2.0.15:0
+ >=media-video/ffmpeg-4.4-r1:0
+ >=dev-qt/qtsvg-5.15.2-r10:5/5.15
+ >=dev-qt/qtquickcontrols2-5.15.2-r11:5
+ >=media-libs/opus-1.3.1-r2:0
+ >=media-sound/pulseaudio-15.0-r1:0
+ vaapi? (
+ >=x11-libs/libva-2.12.0:0
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ dev-qt/qtcore
+"
+
+src_configure() {
+ eqmake5 PREFIX="${D}/usr"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}