aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-27 18:10:12 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-27 18:47:30 +0200
commitc47d5626ecaa7338edd584eddc21b10da8fad0e6 (patch)
tree9b2648c87202475b20b003fb13c5167a7a2aa25e
parentdev-python/avro: initial import (diff)
downloadguru-c47d5626.tar.gz
guru-c47d5626.tar.bz2
guru-c47d5626.zip
dev-python/confluent-kafka: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/confluent-kafka/Manifest1
-rw-r--r--dev-python/confluent-kafka/confluent-kafka-1.7.0.ebuild37
-rw-r--r--dev-python/confluent-kafka/metadata.xml18
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/confluent-kafka/Manifest b/dev-python/confluent-kafka/Manifest
new file mode 100644
index 000000000..16969c2b5
--- /dev/null
+++ b/dev-python/confluent-kafka/Manifest
@@ -0,0 +1 @@
+DIST confluent-kafka-1.7.0.tar.gz 103220 BLAKE2B ac61fb3ce5307f07e6054406d287ef93dad9561e96cc26ba1f9200fcfc931321b157ac2f02a3e96086af2e93aafbbacae2cd77a0c35f53d866e16b17195dc82f SHA512 242736ba1538bef2b9627554e107ec0b435ff78dba321efd3b6feaafea786d6d35641753ea473962962dc0eefca204612483796b68e166f5016618f04c5fd705
diff --git a/dev-python/confluent-kafka/confluent-kafka-1.7.0.ebuild b/dev-python/confluent-kafka/confluent-kafka-1.7.0.ebuild
new file mode 100644
index 000000000..ddafad0ae
--- /dev/null
+++ b/dev-python/confluent-kafka/confluent-kafka-1.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Confluent's Kafka Python Client"
+HOMEPAGE="
+ https://pypi.org/project/confluent-kafka
+ https://github.com/confluentinc/confluent-kafka-python
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/librdkafka
+ >=dev-python/fastavro-1.0[${PYTHON_USEDEP}]
+ >=dev-python/avro-1.10.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/confluent-kafka/metadata.xml b/dev-python/confluent-kafka/metadata.xml
new file mode 100644
index 000000000..d4929d782
--- /dev/null
+++ b/dev-python/confluent-kafka/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">
+confluent-kafka-python provides a high-level Producer, Consumer and AdminClient compatible with all Apache KafkaTM brokers >= v0.8, Confluent Cloud and the Confluent Platform. The client is:
+Reliable - It's a wrapper around librdkafka (provided automatically via binary wheels) which is widely deployed in a diverse set of production scenarios. It's tested using the same set of system tests as the Java client and more. It's supported by Confluent.
+Performant - Performance is a key design consideration. Maximum throughput is on par with the Java client for larger message sizes (where the overhead of the Python interpreter has less impact). Latency is on par with the Java client.
+Future proof - Confluent, founded by the creators of Kafka, is building a streaming platform with Apache Kafka at its core. It's high priority for us that client features keep pace with core Apache Kafka and components of the Confluent Platform.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">confluentinc/confluent-kafka-python</remote-id>
+ <remote-id type="pypi">confluent-kafka</remote-id>
+ </upstream>
+</pkgmetadata>