aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-11-07 22:06:12 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2020-11-07 22:06:12 +0300
commitc56c7d878e5a4c86d4a2316dcbfae24ec58234a0 (patch)
tree78af1c9b264deeeff50a9ca795b161a64ad0c3db
parentgames-board/openriichi: switch vsync ON by default (diff)
downloadguru-c56c7d87.tar.gz
guru-c56c7d87.tar.bz2
guru-c56c7d87.zip
dev-vcs/lazygit: 0.23.7 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
-rw-r--r--dev-vcs/lazygit/Manifest1
-rw-r--r--dev-vcs/lazygit/lazygit-0.23.7.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/lazygit/Manifest b/dev-vcs/lazygit/Manifest
index 8cef6d72e..a8d7e77c6 100644
--- a/dev-vcs/lazygit/Manifest
+++ b/dev-vcs/lazygit/Manifest
@@ -2,3 +2,4 @@ DIST lazygit-0.20.9.tar.gz 9196030 BLAKE2B 7fd64d06b3036926b00cc64f684d48a379156
DIST lazygit-0.22.9.tar.gz 9232631 BLAKE2B 50febf0727dc3fff0e61b158bc37df4128cdc9934a42b113612896a3712fb7cd0ce0a0860eec88cbbde289fd08fb492e851937be549a2036ad993bdeb3a101ae SHA512 9d4dc92762099c141e56bbb386217ea2028ba6a78d6bb5d54ef9c022e447a1b9fa2ce37d6e2813411fe6fa4f5192753beec8b136838aefe067019fd0820225e1
DIST lazygit-0.23.1.tar.gz 2143832 BLAKE2B 631768a0b6e9b3a18742a5fc0d6c71442e6c81aea2ee2eea72320ef0b624b82220be999d878865d798fe00bd86c22f0a8ea9c3c8b8958edc59713ada308645f6 SHA512 f2a4a949888f63c74931ec10cee8551226ce8886d9f6847403490cfa48127c561dfa9b9f7efef879549ab4dccbf06bdf95fdb5a697736f57fb696c658b0e3a39
DIST lazygit-0.23.6.tar.gz 2144643 BLAKE2B d8f8be826212517abfc0dd0feace532600a8455c49874e385257a73ec8e3ea794a13d960fbd122461c454313d5a210cd56be99d98cffb5b47c41d70bd67921d3 SHA512 a71bb951eb452252a97789113664b00212cce4bea223c898b20ce3b3dcdc761d3cafe036b5d2dce20c4da06af361ee21f2e701464ba99dcddc49f383219d2713
+DIST lazygit-0.23.7.tar.gz 2144614 BLAKE2B d18aaa19212ec9e6ed7d3b406d3e1f6413f6c15bf6a8c7c99cb8a2b01b9388db3f1ad04c485782e0823415cec3c6b461cf942583ef0ac744cb18270c8fc943b1 SHA512 ffc827a08a3ba99afa339cee48b9e10267bc4aa27592d43ec1e4be80a7b4f9e628f286b50a1940a59a5cfa96121de6ce4247ec91642a8798dba8ca42232596b9
diff --git a/dev-vcs/lazygit/lazygit-0.23.7.ebuild b/dev-vcs/lazygit/lazygit-0.23.7.ebuild
new file mode 100644
index 000000000..df46884b8
--- /dev/null
+++ b/dev-vcs/lazygit/lazygit-0.23.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/jesseduffield/lazygit"
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Lazygit, a simple terminal UI for git commands"
+HOMEPAGE="https://github.com/jesseduffield/lazygit"
+SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=( sys-libs/glibc )
+RDEPEND=(
+ ${DEPEND}
+ dev-vcs/git
+)
+
+DOCS=( src/${EGO_PN}/{CONTRIBUTING,README}.md )
+
+src_compile() {
+ GOPATH="${S}" go build -v -o bin/lazygit src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/lazygit
+
+ use doc && dodoc -r "src/${EGO_PN}/docs/."
+ einstalldocs
+}