aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-02-27 19:54:51 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-02-27 19:54:51 +0200
commitc7172fc2e9bb011704efbee36e077f80603e8bd9 (patch)
tree60105be4471f9e315b90107d13380411ff0a5a13
parentnet-misc/maestral: drop 1.6.5 (diff)
downloadguru-c7172fc2.tar.gz
guru-c7172fc2.tar.bz2
guru-c7172fc2.zip
net-misc/maestral: add 1.7.1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--net-misc/maestral/Manifest1
-rw-r--r--net-misc/maestral/maestral-1.7.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/maestral/Manifest b/net-misc/maestral/Manifest
index 8703fd7070..89910109e6 100644
--- a/net-misc/maestral/Manifest
+++ b/net-misc/maestral/Manifest
@@ -1,2 +1,3 @@
DIST maestral-1.5.3.gh.tar.gz 8280040 BLAKE2B dcda43880cea3fb00098b6bf87e43318a523a7c9d83886efff58be715cde17f67504b31735a006b951963e5cf0ef70b4b6431cb84200722cae186053a01edd63 SHA512 aa21277623f4e6f3283cd989be910eeb1caa3a842abca595b27a551c1c9bd1e7ef083e495ee0f096190accd91835939cb2f4a26624feae0046d8770d53aaac2f
DIST maestral-1.7.0.gh.tar.gz 7986908 BLAKE2B 0aaf5b573c316a5a575c6a268eef1dd941b77d37a472d5503af4dda366bb54d0ff21b0f8b7d21730de50697d6648f9aff2830eaef0a9f2781503c3d8966e89e6 SHA512 9995f9b05cb1bc033c9cf981095bdcab3e58e6c3a890f6d3194dc6b22233a14fdc9b90a67a56de11d3919b4c13fad12f1dbb9a1b7c090b3bd9a8ec3b7385b963
+DIST maestral-1.7.1.gh.tar.gz 7986892 BLAKE2B 684600d8833ba1b04e32d2f56fdf9e348f3de58af9adbbbd52e2a490ccebc10e5b519c7d4795b1d7f07c4ae95806e9fed6fe5fa898352d8105572a8d2b6d2da9 SHA512 9369e72a3a044c1e985aa85980baca1c44f754eea788991d993868408ba886fcb2671fe1098865a3d10cced84793f74e36446f9cd882db968285525643c0b606
diff --git a/net-misc/maestral/maestral-1.7.1.ebuild b/net-misc/maestral/maestral-1.7.1.ebuild
new file mode 100644
index 0000000000..33e31a844f
--- /dev/null
+++ b/net-misc/maestral/maestral-1.7.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 xdg
+
+MY_PV=${PV/_rc/.dev}
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ >=dev-python/desktop-notifier-3.3.0[${PYTHON_USEDEP}]
+ =dev-python/dropbox-11*[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.15[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/keyring-22.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keyrings-alt-3.1.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.5.8[${PYTHON_USEDEP}]
+ >=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ =dev-python/survey-3*[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ # requires dev-python/pytest-benchmark not available for py3.11
+ tests/offline/test_clean_local_events.py::test_performance
+
+ # requires systemd
+ tests/offline/test_cli.py::test_autostart
+
+ # requires network
+ tests/offline/test_main.py::test_check_for_updates
+)
+
+distutils_enable_tests pytest