aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-09-28 02:27:21 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-09-28 02:27:21 +0200
commitc8dd634f37b462cba0b748d1c7855af9229a79e4 (patch)
treefc507393ed6c7631175c738b65c8c45afab34860
parentdev-util/deblob: Fix QA_FLAGS_IGNORED (diff)
downloadguru-c8dd634f.tar.gz
guru-c8dd634f.tar.bz2
guru-c8dd634f.zip
dev-util/deblob: add 0.1
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
-rw-r--r--dev-util/deblob/Manifest1
-rw-r--r--dev-util/deblob/deblob-0.1.ebuild26
-rw-r--r--dev-util/deblob/deblob-9999.ebuild12
3 files changed, 34 insertions, 5 deletions
diff --git a/dev-util/deblob/Manifest b/dev-util/deblob/Manifest
new file mode 100644
index 000000000..d534dd726
--- /dev/null
+++ b/dev-util/deblob/Manifest
@@ -0,0 +1 @@
+DIST deblob-0.1.tar.gz 10553 BLAKE2B 42253d68d2f424a5a40615b439d126a85ab66e1983e27b2e707ec8914452b2b1d263ee073a62ab5e96a3f3def59271a7301dbb85859c7f61851f7e67a88006ce SHA512 2979e676ebcc41c18a3fbcc041427b1e3515203c070da88bef63946c9449e2e3e7f7b26d563b9b8e11979673436fb05a355b5014496fc708eeffade1cea1ac3a
diff --git a/dev-util/deblob/deblob-0.1.ebuild b/dev-util/deblob/deblob-0.1.ebuild
new file mode 100644
index 000000000..c7aef7e2e
--- /dev/null
+++ b/dev-util/deblob/deblob-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ "$PV" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~lanodan/deblob"
+else
+ SRC_URI="https://hacktivis.me/releases/${P}.tar.gz"
+fi
+
+DESCRIPTION="remove binary executables from a directory"
+HOMEPAGE="https://git.sr.ht/~lanodan/deblob"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-lang/hare:="
+RDEPEND=""
+
+# built by hare
+QA_FLAGS_IGNORED="usr/bin/deblob"
+
+src_install() {
+ PREFIX="/usr" default
+}
diff --git a/dev-util/deblob/deblob-9999.ebuild b/dev-util/deblob/deblob-9999.ebuild
index 3c186d3a6..c7aef7e2e 100644
--- a/dev-util/deblob/deblob-9999.ebuild
+++ b/dev-util/deblob/deblob-9999.ebuild
@@ -3,17 +3,19 @@
EAPI=8
-inherit git-r3
+if [[ "$PV" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~lanodan/deblob"
+else
+ SRC_URI="https://hacktivis.me/releases/${P}.tar.gz"
+fi
DESCRIPTION="remove binary executables from a directory"
HOMEPAGE="https://git.sr.ht/~lanodan/deblob"
-EGIT_REPO_URI="https://git.sr.ht/~lanodan/deblob"
LICENSE="BSD"
SLOT="0"
-DEPEND="
- dev-lang/hare:=
-"
+DEPEND="dev-lang/hare:="
RDEPEND=""
# built by hare