aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2022-09-09 15:43:17 +0200
committerSamuel Bauer <samuel.bauer@yahoo.fr>2022-09-09 15:49:41 +0200
commitc927e2cc777459cc6295372c8b7b0ff9001ecd5c (patch)
treec882a6626929886bde10363190b87d18256b1f96
parentgui-wm/dwl: fixed libxcb dependency (diff)
downloadguru-c927e2cc.tar.gz
guru-c927e2cc.tar.bz2
guru-c927e2cc.zip
games-emulation/yuzu: update live ebuild
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
-rw-r--r--games-emulation/yuzu/yuzu-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-emulation/yuzu/yuzu-9999.ebuild b/games-emulation/yuzu/yuzu-9999.ebuild
index 0860eda94..7fdca80d6 100644
--- a/games-emulation/yuzu/yuzu-9999.ebuild
+++ b/games-emulation/yuzu/yuzu-9999.ebuild
@@ -49,7 +49,6 @@ DEPEND="${RDEPEND}
system-vulkan? ( >=dev-util/vulkan-headers-1.3.216 )
"
BDEPEND="
- test? ( <dev-cpp/catch-3:0 )
>=dev-cpp/nlohmann_json-3.8.0
dev-cpp/robin-map
dev-util/glslang
@@ -74,6 +73,10 @@ src_unpack() {
EGIT_SUBMODULES+=('Vulkan-Headers')
fi
+ if use test; then
+ EGIT_SUBMODULES+=('Catch2')
+ fi
+
git-r3_src_unpack
# Do not fetch via sources because this file always changes
use compatibility-list && curl https://api.yuzu-emu.org/gamedb/ > "${S}"/compatibility_list.json
@@ -104,12 +107,10 @@ src_prepare() {
# Unbundle mbedtls: undefined reference to `mbedtls_cipher_cmac'
sed -i -e '/mbedtls/d' externals/CMakeLists.txt || die
+ sed -i -e 's/mbedtls/& mbedcrypto mbedx509/'
sed -i -e 's/mbedtls/& mbedcrypto mbedx509/' \
- -e '1ifind_path(MBEDTLS_INCLUDE_DIR NAMES mbedtls/ssl.h)' \
- -e '1ifind_library(MBEDTLS_LIB NAMES mbedtls)' \
- -e '1ifind_library(MBEDX509_LIB NAMES mbedx509)' \
- -e '1ifind_library(MBEDCRYPTO_LIB NAMES mbedcrypto)' \
- src/core/CMakeLists.txt
+ src/dedicated_room/CMakeLists.txt \
+ src/core/CMakeLists.txt || die
# Workaround: GenerateSCMRev fails
sed -i -e "s/@GIT_BRANCH@/${EGIT_BRANCH:-master}/" \