aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-11-08 18:20:07 +0100
committerMaciej Barć <xgqt@protonmail.com>2020-11-08 18:20:17 +0100
commitc986e5a0674446f395670ff584252c0ef6ebe3a0 (patch)
tree3b1d49821c1aa1fd7dadb889c1ffcd437590060b
parentsci-visualization/scidavis: fix metadata (diff)
downloadguru-c986e5a0.tar.gz
guru-c986e5a0.tar.bz2
guru-c986e5a0.zip
x11-misc/gammy: bump to 0.9.59
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
-rw-r--r--x11-misc/gammy/Manifest1
-rw-r--r--x11-misc/gammy/gammy-0.9.59.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-misc/gammy/Manifest b/x11-misc/gammy/Manifest
index f0d51f1bab..7534ccf43d 100644
--- a/x11-misc/gammy/Manifest
+++ b/x11-misc/gammy/Manifest
@@ -1 +1,2 @@
DIST gammy-0.9.58a.tar.gz 208411 BLAKE2B 1681f5bbe49d8645a5f55be338c82fe6728bd2b643d5cff1343a3c3bc00ba06c7a903a1c4c6d8ca21f1e2e2991ecec79c392f17aeacb75f1b17f0994cc05b1f6 SHA512 fced7b742e15a70933146901dc07c8375bd7fffc6e000e8fa323029366e09d090c9c9c3e5d783fc5ad923259abf798649652af40e1a9bc83f6c60cbb81ee53a8
+DIST gammy-0.9.59.tar.gz 209514 BLAKE2B 948bc841361217cde846288e93e67ed944d99fdf682f56a42e85036fe2455ba900f3c80bda712012116280bd2f2a6038f2cb4d783fcc7e2037f2df096c486b6e SHA512 1fd1255f9681b1b59457ad817e604cf73cc81397e927db62d3f53a1c39f7b634544c50931ece71f116f2f01c7fb7d7dc33696e0400fe23785b2a23b112bd8aa5
diff --git a/x11-misc/gammy/gammy-0.9.59.ebuild b/x11-misc/gammy/gammy-0.9.59.ebuild
new file mode 100644
index 0000000000..3a75f14f22
--- /dev/null
+++ b/x11-misc/gammy/gammy-0.9.59.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils qmake-utils xdg
+
+DESCRIPTION="Adaptive screen brightness/temperature"
+HOMEPAGE="https://getgammy.com/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Fushko/${PN}.git"
+else
+ SRC_URI="https://github.com/Fushko/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ x11-libs/libXxf86vm
+"
+DEPEND="
+ ${RDEPEND}
+ media-gfx/imagemagick
+"
+
+src_configure() {
+ eqmake5 PREFIX="${D}/usr"
+}
+
+src_install() {
+ default
+
+ local sizes="
+ 128
+ 16
+ 32
+ 64
+ "
+ cd ./icons || die
+ for size in ${sizes}; do
+ convert "${size}x${size}ball.ico" "${size}x${size}ball.png" || die
+ newicon -s "${size}" "${size}x${size}ball.png" "${PN}.png"
+ done
+
+ make_desktop_entry "${PN}" "${PN^}" "${PN}" "Graphics;Settings"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}