aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Egger <egger.m@protonmail.com>2023-01-02 18:01:46 +0100
committerMichael Egger <egger.m@protonmail.com>2023-01-02 18:01:46 +0100
commitca65e89eca3f06cdc823dd24ef27b910e77a29f6 (patch)
treeb07ba379511cb4a4041fbbfecf60c1797b6ba118
parentnet-p2p/monero: update SRC_URI (diff)
downloadguru-ca65e89e.tar.gz
guru-ca65e89e.tar.bz2
guru-ca65e89e.zip
app-portage/portage-lostfiles: add 0.5.2, drop 0.2.2
Signed-off-by: Michael Egger <egger.m@protonmail.com>
-rw-r--r--app-portage/portage-lostfiles/Manifest2
-rw-r--r--app-portage/portage-lostfiles/metadata.xml37
-rw-r--r--app-portage/portage-lostfiles/portage-lostfiles-0.5.2.ebuild (renamed from app-portage/portage-lostfiles/portage-lostfiles-0.2.2.ebuild)7
3 files changed, 24 insertions, 22 deletions
diff --git a/app-portage/portage-lostfiles/Manifest b/app-portage/portage-lostfiles/Manifest
index 2ae44a804..dd31f2636 100644
--- a/app-portage/portage-lostfiles/Manifest
+++ b/app-portage/portage-lostfiles/Manifest
@@ -1 +1 @@
-DIST portage-lostfiles-0.2.2.tar.gz 10618 BLAKE2B a477bafc83d5af7d29759bcaa3c09a89f678a463a94f037689bdef3e85cf3b78bdc53aed87696aa351623c6be210937f50d6f71ef588d9e27dbed061300374af SHA512 cf7b17d9cd3214616f4bb60284275172e4270180a87f4934e6ee5750e62315b2728e4fa0f930c18fc02b4b173b404fa27c3e75fca4f5ae0b740fe0c91025cb36
+DIST portage-lostfiles-0.5.2.tar.gz 12554 BLAKE2B 3562c6e0fad3fb4d41b815bf8183826875ef169c068a9c2c0e1370aadf7524ff1b1c06f3a39133f626a6bf520e4ba27e6de31e5dd66dbbbe818a1d4719266ecd SHA512 6418a8bb526e2bd62f1dda1f2f3cc715db0a3df125ccec47347fb93cba12214270d92768d2aafeac2e5487f34832a5c1abab6e0e3dde7dd4ec44bc0881af6764
diff --git a/app-portage/portage-lostfiles/metadata.xml b/app-portage/portage-lostfiles/metadata.xml
index 5daf1a751..a09f34b3d 100644
--- a/app-portage/portage-lostfiles/metadata.xml
+++ b/app-portage/portage-lostfiles/metadata.xml
@@ -1,22 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>egger.m@protonmail.com</email>
- <name>Michael Egger</name>
- </maintainer>
- <longdescription lang="en">
- A simple script to identify files not tracked by Portage package manager.
- Notes:
- Symlinks are not reported as lost as long as the link target exists and is tracked.
- Some common paths are not reported (e.g.: /etc/group, /etc/machine-id, ...). The full whitelist is defined by WHITELIST in lostfiles.py.
- Usage
- git clone https://github.com/gcarq/portage-lostfiles.git
- cd portage-lostfiles
- $ ./lostfiles.py
- </longdescription>
- <upstream>
- <bugs-to>https://github.com/gcarq/portage-lostfiles/issues</bugs-to>
- <doc>https://github.com/gcarq/portage-lostfiles/blob/master/README.md</doc>
- </upstream>
+ <maintainer type="person">
+ <email>egger.m@protonmail.com</email>
+ <name>Michael Egger</name>
+ </maintainer>
+ <longdescription lang="en">
+ A simple script to identify files not tracked by Portage package manager.
+ Notes
+ Symlinks are not reported as lost as long as the link target exists and is tracked,
+ this is the same behavior as implemented in `equery b path`.
+ Some common paths are not reported (e.g.: `/etc/group`, `/etc/machine-id`, ...),
+ those are defined in `IGNORED_PATHS` and `PKG_PATHS` in `lostfiles.py`.
+ Usage
+ git clone https://github.com/gcarq/portage-lostfiles.git
+ cd portage-lostfiles
+ $ ./lostfiles.py
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gcarq/portage-lostfiles</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-portage/portage-lostfiles/portage-lostfiles-0.2.2.ebuild b/app-portage/portage-lostfiles/portage-lostfiles-0.5.2.ebuild
index 06a33a36e..6cd8a7426 100644
--- a/app-portage/portage-lostfiles/portage-lostfiles-0.2.2.ebuild
+++ b/app-portage/portage-lostfiles/portage-lostfiles-0.5.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A simple script to identify files not tracked by Portage package manager"