aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-16 15:49:02 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-16 17:12:18 +0200
commitcba25d034631d28c66dd7799455b3025d09bdfe4 (patch)
tree9d11c39b5aea6acdcc04e3bf70f1e45e547eedd0
parentdev-perl/HTTP-Tiny-Multipart: new package (diff)
downloadguru-cba25d03.tar.gz
guru-cba25d03.tar.bz2
guru-cba25d03.zip
dev-util/devscripts: new package
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-util/devscripts/Manifest1
-rw-r--r--dev-util/devscripts/devscripts-2.21.2.ebuild119
-rw-r--r--dev-util/devscripts/files/Remove-failing-tests.patch22
-rw-r--r--dev-util/devscripts/files/Replace-Debian-xsl-stylesheets-paths-with-Gentoos.patch42
-rw-r--r--dev-util/devscripts/files/distutils-r1.patch26
-rw-r--r--dev-util/devscripts/metadata.xml9
6 files changed, 219 insertions, 0 deletions
diff --git a/dev-util/devscripts/Manifest b/dev-util/devscripts/Manifest
new file mode 100644
index 000000000..a372dd94f
--- /dev/null
+++ b/dev-util/devscripts/Manifest
@@ -0,0 +1 @@
+DIST devscripts_2.21.2.tar.xz 980516 BLAKE2B 907f2f4e258a8396ad0a28eead1e2058b8e19be205f024ea80c0fbd9621d5ca4299844fe83d66cac7f653a917705d9c36eddb9d51454a7fbb9d7e2b52bc994ff SHA512 a6765d807dc0c2ef7a3d8c59e1262bfe7542c3ca52cda3c1910af253925cb105a9d1bf272c76a86f0b3cdda9c8a4e2d29a660437f73087dd70ee8a444bbedb01
diff --git a/dev-util/devscripts/devscripts-2.21.2.ebuild b/dev-util/devscripts/devscripts-2.21.2.ebuild
new file mode 100644
index 000000000..e5fc18145
--- /dev/null
+++ b/dev-util/devscripts/devscripts-2.21.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_OPTIONAL=true
+
+inherit distutils-r1
+
+DESCRIPTION="Scripts to make the life of a Debian Package maintainer easier"
+HOMEPAGE="https://salsa.debian.org/debian/devscripts"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ dev-lang/perl:=
+ dev-perl/File-DesktopEntry
+ dev-perl/File-DirList
+ dev-perl/File-HomeDir
+ dev-perl/File-Touch
+ dev-perl/IPC-Run
+ dev-perl/Moo
+ dev-perl/libwww-perl
+ dev-util/distro-info
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${CDEPEND}
+ app-shells/bash-completion
+ test? (
+ app-arch/zip
+ dev-perl/Git-Wrapper
+ dev-perl/GitLab-API-v4
+ dev-perl/List-Compare
+ dev-perl/Software-License
+ dev-perl/String-ShellQuote
+ dev-perl/UNIVERSAL-require
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/python-debian[${PYTHON_USEDEP}]
+ dev-util/shunit2
+ dev-vcs/subversion
+ sys-libs/libfaketime
+ virtual/perl-DB_File
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ app-arch/dpkg
+ app-crypt/gnupg
+ app-text/wdiff
+ dev-util/debhelper
+ dev-util/patchutils
+ sys-apps/fakeroot
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/distutils-r1.patch"
+ "${FILESDIR}/Remove-failing-tests.patch"
+ "${FILESDIR}/Replace-Debian-xsl-stylesheets-paths-with-Gentoos.patch"
+)
+
+DISTUTILS_S="${S}"/scripts
+
+src_prepare() {
+ default
+
+ # Avoid file collision with app-shells/bash-completion
+ rm "${DISTUTILS_S}"/bts.bash_completion || die
+}
+
+src_configure() {
+ default
+
+ if use python; then
+ pushd "${DISTUTILS_S}" > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd "${DISTUTILS_S}" > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ default
+
+ if use python; then
+ pushd "${DISTUTILS_S}" > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ default
+
+ if use python; then
+ pushd "${DISTUTILS_S}" > /dev/null || die
+ distutils-r1_src_test
+ popd > /dev/null || die
+ fi
+}
diff --git a/dev-util/devscripts/files/Remove-failing-tests.patch b/dev-util/devscripts/files/Remove-failing-tests.patch
new file mode 100644
index 000000000..ed0726a90
--- /dev/null
+++ b/dev-util/devscripts/files/Remove-failing-tests.patch
@@ -0,0 +1,22 @@
+--- a/test/Makefile
++++ b/test/Makefile
+@@ -3,14 +3,14 @@
+ perl \
+ annotate-output \
+ checkbashisms \
+- dd-list \
++ \
+ debchange \
+ debdiff \
+- debrepro \
++ \
+ debsign \
+ mergechanges \
+- mk-origtargz \
++ \
+- package_lifecycle \
++ \
+- sadt \
++ \
+ uscan \
+ uscan_ftp \
diff --git a/dev-util/devscripts/files/Replace-Debian-xsl-stylesheets-paths-with-Gentoos.patch b/dev-util/devscripts/files/Replace-Debian-xsl-stylesheets-paths-with-Gentoos.patch
new file mode 100644
index 000000000..6b7294041
--- /dev/null
+++ b/dev-util/devscripts/files/Replace-Debian-xsl-stylesheets-paths-with-Gentoos.patch
@@ -0,0 +1,42 @@
+--- a/po4a/Makefile
++++ b/po4a/Makefile
+@@ -34,8 +34,8 @@
+ pod2man --utf8 --center=" " --release="$(DESC_$(dir $@))" $< > $@
+ %.1:: %.dbk translate
+ xsltproc --nonet \
+- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
+- # /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/other.xsl
++ /usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl $<
++ # /usr/share/sgml/docbook/xsl-stylesheets/manpages/other.xsl
+ # (which is imported by the above stylesheet) insists in writing the output
+ # to where it wants to. we can only move the file ourselves.
+ # ($* → de/deb-reversion.de)
+--- a/scripts/deb-reversion.dbk
++++ b/scripts/deb-reversion.dbk
+@@ -5,13 +5,13 @@
+ <!--
+
+ Process this file with an XSLT processor: `xsltproc \
+--''-nonet /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/\
++-''-nonet /usr/share/sgml/docbook/xsl-stylesheets/\
+ manpages/docbook.xsl manpage.dbk'. A manual page
+ <package>.<section> will be generated. You may view the
+ manual page with: nroff -man <package>.<section> | less'. A
+ typical entry in a Makefile or Makefile.am is:
+
+-DB2MAN=/usr/share/sgml/docbook/stylesheet/xsl/nwalsh/\
++DB2MAN=/usr/share/sgml/docbook/xsl-stylesheets/\
+ manpages/docbook.xsl
+ XP=xsltproc -''-nonet
+
+--- a/scripts/Makefile
++++ b/scripts/Makefile
+@@ -87,7 +87,7 @@
+ pod2man --utf8 --center=" " --release="Debian Utilities" $< > $@
+ %.1: %.dbk
+ xsltproc --nonet -o $@ \
+- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
++ /usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl $<
+
+ # Syntax checker
+ test_sh: $(SH_CHECKS)
diff --git a/dev-util/devscripts/files/distutils-r1.patch b/dev-util/devscripts/files/distutils-r1.patch
new file mode 100644
index 000000000..7b6b526f0
--- /dev/null
+++ b/dev-util/devscripts/files/distutils-r1.patch
@@ -0,0 +1,26 @@
+--- a/scripts/Makefile
++++ b/scripts/Makefile
+@@ -99,7 +99,6 @@
+ perl -I ../lib -c $<; \
+
+ test_py: $(VERSION_FILE)
+- $(foreach python,$(shell py3versions -r ../debian/control),$(python) setup.py test$(\n))
+
+ debbisect.1: debbisect
+ help2man \
+@@ -131,7 +130,6 @@
+ cp $< $@
+
+ clean:
+- python3 setup.py clean -a
+ find -name '*.pyc' -delete
+ find -name __pycache__ -delete
+ rm -rf devscripts.egg-info $(BC_BUILD_DIR) .pylint.d
+@@ -142,7 +140,6 @@
+ test: test_pl test_sh test_py
+
+ install: all
+- python3 setup.py install --root="$(DESTDIR)" --no-compile --install-layout=deb
+ cp $(SCRIPTS) $(DESTDIR)$(BINDIR)
+ ln -sf edit-patch $(DESTDIR)$(BINDIR)/add-patch
+ install -d $(DESTDIR)$(COMPL_DIR)
diff --git a/dev-util/devscripts/metadata.xml b/dev-util/devscripts/metadata.xml
new file mode 100644
index 000000000..a6ffcfbc7
--- /dev/null
+++ b/dev-util/devscripts/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>comaintainers welcome</description>
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+</pkgmetadata>