aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Davies <gentoo-guru@steev.me.uk>2021-05-16 19:38:11 +0100
committerSteven Davies <gentoo-guru@steev.me.uk>2021-05-16 19:38:11 +0100
commitcda326bc4e2c42f159312ec9347ae5678f23cfc0 (patch)
treee50fc869d4b431e21b001eecb3abc12bcefa1e47
parentgames-emulation/melonds: suppress QA_EXECSTACK (diff)
downloadguru-cda326bc.tar.gz
guru-cda326bc.tar.bz2
guru-cda326bc.zip
sys-fs/python-btrfs: Version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Steven Davies <gentoo-guru@steev.me.uk>
-rw-r--r--sys-fs/python-btrfs/Manifest1
-rw-r--r--sys-fs/python-btrfs/python-btrfs-13.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/python-btrfs/Manifest b/sys-fs/python-btrfs/Manifest
index c97445d33..6ef6e6aeb 100644
--- a/sys-fs/python-btrfs/Manifest
+++ b/sys-fs/python-btrfs/Manifest
@@ -1 +1,2 @@
DIST python-btrfs-12.tar.gz 92369 BLAKE2B bc899900c4d436ca4ad940247ac6edc9022f09f604c4c9b78288065e8950a9ba86147d1d9992e2410edb9907a2e7748467b1ae92d33b21c6e7ab9149c84431e3 SHA512 93d7ac4b0c8cc62e5a89b0ffd269695c2c52a4111385ec00d2cb467b6d1c35e59a450c128ca4ddedf91955f51962092ec2e2431ce3d9243d25beeaa2d2ec38ac
+DIST python-btrfs-13.tar.gz 93110 BLAKE2B 286e5d1d9aa66ce5072f2fe144b2da6bbcde65dd90eb21efe1eb69b9aaa3230d76e8b8baffcfd269ce5d53e1004b5fc6c5546125bc1a5c26413ba8abc66f068a SHA512 5117b9c6542fe191eccbed56a15bb5d8eadc2d3c0edd986a3e1a33d0b63f58c3db5e7f6d234c43a83d1cc74eea3e106c5882a92926c3087601edc36e6672721f
diff --git a/sys-fs/python-btrfs/python-btrfs-13.ebuild b/sys-fs/python-btrfs/python-btrfs-13.ebuild
new file mode 100644
index 000000000..f61c7435f
--- /dev/null
+++ b/sys-fs/python-btrfs/python-btrfs-13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS="no"
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 module to inspect btrfs filesystems"
+HOMEPAGE="https://github.com/knorrie/python-btrfs"
+SRC_URI="https://github.com/knorrie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ use examples && local DOCS=( README.md CHANGES examples )
+ distutils-r1_python_install_all
+}