aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-07-06 05:04:07 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-07-06 05:04:07 +0200
commitce106d4a01e786d585a1d9bd5d44fe3d80a5153c (patch)
tree25d5acb9d0fe7167e0e414c937096e47fc32bf20
parentnet-misc/gemserv: Remove old ebuilds. (diff)
downloadguru-ce106d4a.tar.gz
guru-ce106d4a.tar.bz2
guru-ce106d4a.zip
dev-libs/tweeny: Version bump 3.1.1.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--dev-libs/tweeny/Manifest1
-rw-r--r--dev-libs/tweeny/tweeny-3.1.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/tweeny/Manifest b/dev-libs/tweeny/Manifest
index f11cb8539..1db1ee873 100644
--- a/dev-libs/tweeny/Manifest
+++ b/dev-libs/tweeny/Manifest
@@ -1 +1,2 @@
DIST tweeny-3.1.0.tar.gz 49467 BLAKE2B 7b1a3b7a7dba22d291c89dc3b2ee07458070aa55f2e77adfc1f0de4095187d2a2e0e0960a17a17fd96cccdd114d42d5e1bb4a6a76edc4b97500b2615c0eb574e SHA512 8109c241f866b565d15f1f5f87837f178a4fd3c5169d73e73e18334c54274024b48c9baed1f1935201ab872687bacb9ff3f8ecbae8078de4e1b459242450b9a5
+DIST tweeny-3.1.1.tar.gz 49663 BLAKE2B 1528e4ed6a42101fb96cc5283ee72a5546ae73b04fd8bc888902060410b94716fe6b3513fcf705553cd1f6c587aa23a26915b45aa592cd7f59bb83dcf1d64eac SHA512 3bffa130364512c9bb91b2cba73fc55833eafd9841e35dfccec68d6f865d571dfdb526c0af16124cdf9ce25b9c9f1a6097122075067e84746ede1b733e81d74b
diff --git a/dev-libs/tweeny/tweeny-3.1.1.ebuild b/dev-libs/tweeny/tweeny-3.1.1.ebuild
new file mode 100644
index 000000000..f1e6d960f
--- /dev/null
+++ b/dev-libs/tweeny/tweeny-3.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ tweening (inbetweening) library"
+HOMEPAGE="https://mobius3.github.io/tweeny/"
+SRC_URI="https://github.com/mobius3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use doc; then
+ sed -i "s@DESTINATION share/doc/Tweeny@DESTINATION share/doc/${PF}@" \
+ doc/CMakeLists.txt || die "Could not change documentation path."
+ fi
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DTWEENY_BUILD_DOCUMENTATION=$(usex doc)
+ )
+
+ cmake_src_configure
+}