aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2020-04-07 15:42:49 +0800
committerHuang Rui <vowstar@gmail.com>2020-04-07 15:42:50 +0800
commitcecea0e4617aaee27bedec39491edbcce3e42298 (patch)
treec1253e52947cc5fc3fca515775b01dd1eb6c5337
parenteclass/docs: one more bug fix (diff)
downloadguru-cecea0e4617aaee27bedec39491edbcce3e42298.tar.gz
guru-cecea0e4617aaee27bedec39491edbcce3e42298.tar.bz2
guru-cecea0e4617aaee27bedec39491edbcce3e42298.zip
x11-themes/obsidian-icon-theme: new package of 2.11
Intuitive Faenza-like icon theme https://github.com/madmaxms/iconpack-obsidian Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Huang Rui <vowstar@gmail.com>
-rw-r--r--x11-themes/obsidian-icon-theme/Manifest1
-rw-r--r--x11-themes/obsidian-icon-theme/metadata.xml7
-rw-r--r--x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.11.ebuild34
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/obsidian-icon-theme/Manifest b/x11-themes/obsidian-icon-theme/Manifest
new file mode 100644
index 000000000..31bac64bf
--- /dev/null
+++ b/x11-themes/obsidian-icon-theme/Manifest
@@ -0,0 +1 @@
+DIST obsidian-icon-theme-4.11.tar.gz 70016310 BLAKE2B 138824ee333eb225eaa7d22cd3e8cb05d374b78f3dd0ce194fe489fb34f16b8e4eb9f752006ff5c73c8467db6edf4bbb662adfbe1a4ed5296af4d1484c70321c SHA512 e0dcf1085a293d2ec64fe649e7e6fd9f705da8b0559f4ca4da14ef58809c21a8c21346fcafeb9717c7f45e566aee0ed6422b4edf4687bbabf62cd0ad69985eaf
diff --git a/x11-themes/obsidian-icon-theme/metadata.xml b/x11-themes/obsidian-icon-theme/metadata.xml
new file mode 100644
index 000000000..52536a956
--- /dev/null
+++ b/x11-themes/obsidian-icon-theme/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.11.ebuild b/x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.11.ebuild
new file mode 100644
index 000000000..938007106
--- /dev/null
+++ b/x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GIT_PN="iconpack-obsidian"
+
+DESCRIPTION="Obsidian Icon Theme"
+
+HOMEPAGE="https://github.com/madmaxms/${GIT_PN}"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/madmaxms/${GIT_PN}.git"
+else
+ SRC_URI="https://github.com/madmaxms/${GIT_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ x11-themes/adwaita-icon-theme
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r Obsidian*
+}