aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2022-01-27 14:39:56 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2022-01-27 14:42:02 +0100
commitcfcfbcbb928e795646537a51242c2e46892dd233 (patch)
tree480fbdbf31aa164fe886cb5dd6c57ef3dfbc3351
parentdev-util/rust-analyzer: add 20220124, drop 20220110 (diff)
downloadguru-cfcfbcbb.tar.gz
guru-cfcfbcbb.tar.bz2
guru-cfcfbcbb.zip
media-sound/spotify_dl: bump to 8.0.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
-rw-r--r--media-sound/spotify_dl/Manifest1
-rw-r--r--media-sound/spotify_dl/files/spotify_dl-8.0.0-fuzzy-requirements.patch20
-rw-r--r--media-sound/spotify_dl/spotify_dl-8.0.0.ebuild41
3 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/spotify_dl/Manifest b/media-sound/spotify_dl/Manifest
index eea696570..22d0f0182 100644
--- a/media-sound/spotify_dl/Manifest
+++ b/media-sound/spotify_dl/Manifest
@@ -1 +1,2 @@
DIST spotify_dl-7.6.0.tar.gz 319723 BLAKE2B 9b0bb4c4839226b83ce6b7f0e030c5136de47f84e4c5f069b9fe573755746a12e0b32a8ad488704aae4a5355920289d9f2e7e955a950b3e9d7c7d78f24f26928 SHA512 21f8111f679c028b71371aa3d8bd822c0e72474fb768834a5f3c84fd3491e74e56bbf7acf0c23a132cdb60ac99dbcb65d4ca60f388ee48cbaeb1b66528bd06a5
+DIST spotify_dl-8.0.0.tar.gz 320100 BLAKE2B a0ad0f732f244b8140f6278ca99c1a392d73455750fec1a97226fc607d3b7a1d226c2629ea3674173f8f9d0ef059c910c7e549f42b68fdbdc03efa4b07435818 SHA512 7c8d385b6777c89a4a75a7b1fc63bfcf20552a1c23e48a80d0688af0d51285085ebfb418ec5b94becd84870a07fc347ade31b6d2da511c000161489cccba23ed
diff --git a/media-sound/spotify_dl/files/spotify_dl-8.0.0-fuzzy-requirements.patch b/media-sound/spotify_dl/files/spotify_dl-8.0.0-fuzzy-requirements.patch
new file mode 100644
index 000000000..fecc8e667
--- /dev/null
+++ b/media-sound/spotify_dl/files/spotify_dl-8.0.0-fuzzy-requirements.patch
@@ -0,0 +1,20 @@
+Accept a wider range of versions, the provided ones are too
+restrictive and sometimes outside the gentoo tree.
+Patch by Nicola Smaniotto.
+
+diff --git a/requirements.txt b/requirements.txt
+index 586b007..987eeb2 100644
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -1,5 +1,5 @@
+-sentry_sdk==1.5.3
+-yt-dlp>=2022.01.21
+-spotipy==2.16.1
+-mutagen==1.45.1
+-rich==11.0.0
+\ No newline at end of file
++sentry_sdk>=1.5, <2
++yt-dlp>=2021.10.27
++spotipy>=2.16, <3
++mutagen>=1.45, <2
++rich>=11.0, <12
diff --git a/media-sound/spotify_dl/spotify_dl-8.0.0.ebuild b/media-sound/spotify_dl/spotify_dl-8.0.0.ebuild
new file mode 100644
index 000000000..aebf95422
--- /dev/null
+++ b/media-sound/spotify_dl/spotify_dl-8.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/_/-}"
+
+DESCRIPTION="Downloads songs from a Spotify Playlist/Track/Album that you provide"
+HOMEPAGE="https://github.com/SathyaBhat/spotify-dl/"
+SRC_URI="https://github.com/SathyaBhat/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="
+ >=dev-python/sentry-sdk-1.5[${PYTHON_USEDEP}]
+ <dev-python/sentry-sdk-2[${PYTHON_USEDEP}]
+ net-misc/yt-dlp[${PYTHON_USEDEP}]
+ >=dev-python/spotipy-2.16[${PYTHON_USEDEP}]
+ <dev-python/spotipy-3[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-1.45[${PYTHON_USEDEP}]
+ <media-libs/mutagen-2[${PYTHON_USEDEP}]
+ >=dev-python/rich-11.0[${PYTHON_USEDEP}]
+ <dev-python/rich-12[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/"${P}"-fuzzy-requirements.patch
+)
+
+distutils_enable_tests pytest