aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 18:59:33 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 19:02:51 +0200
commitd092d2163bb287872d88c379841f87141448c3a8 (patch)
tree7da1d6041aafa799f9f1758ca8a7da4376f1cfd7
parentmpv-plugin/mpv-youtube-upnext: update Manifest (diff)
downloadguru-d092d216.tar.gz
guru-d092d216.tar.bz2
guru-d092d216.zip
media-libs/lodepng: remove stray file
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--media-libs/lodepng/Makefile37
1 files changed, 0 insertions, 37 deletions
diff --git a/media-libs/lodepng/Makefile b/media-libs/lodepng/Makefile
deleted file mode 100644
index 6731999d9b..0000000000
--- a/media-libs/lodepng/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# This makefile only makes the unit test, benchmark and pngdetail and showpng
-# utilities. It does not make the PNG codec itself as shared or static library.
-# That is because:
-# LodePNG itself has only 1 source file (lodepng.cpp, can be renamed to
-# lodepng.c) and is intended to be included as source file in other projects and
-# their build system directly.
-
-
-CC ?= gcc
-CXX ?= g++
-
-CFLAGS += -W -Wall -Wextra -ansi -pedantic -Wno-unused-function
-CXXFLAGS += -W -Wall -Wextra -ansi -pedantic
-
-all: unittest benchmark pngdetail showpng lodepng.so
-
-%.o: %.cpp
- @mkdir -p `dirname $@`
- $(CXX) -I ./ $(CXXFLAGS) -fPIC -c $< -o $@
-
-lodepng.so: lodepng.o
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -fPIC -shared -Wl,-soname,lodepngn.so $^ -o $@
-
-unittest: lodepng.so lodepng_util.o lodepng_unittest.o
- $(CXX) $^ $(CXXFLAGS) $(LDFLAGA) -fPIE -o $@ -L. -llodepng
-
-benchmark: lodepng.so lodepng_benchmark.o
- $(CXX) $^ $(CXXFLAGS) $(LDFLAGS) -fPIE -lSDL -o $@ -L. -llodepng
-
-pngdetail: lodepng.so lodepng_util.o pngdetail.o
- $(CXX) $^ $(CXXFLAGS) $(LDFLAGS) -fPIE -o $@ -L. -llodepng
-
-showpng: lodepng.so examples/example_sdl.o
- $(CXX) -I ./ $^ $(CXXFLAGS) $(LDFLAGS) -fPIE -lSDL -o $@ -L. -llodepng
-
-clean:
- rm -f unittest benchmark pngdetail showpng lodepng_unittest.o lodepng_benchmark.o lodepng.o lodepng_util.o pngdetail.o examples/example_sdl.o