aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2021-04-29 22:04:42 +0200
committerSamuel Bauer <samuel.bauer@yahoo.fr>2021-04-29 22:04:42 +0200
commitd09ae1a39e6408d3577ef7037fc8738b83aaeae8 (patch)
tree9d359adfe361dd0aa06d7c1e5f9a47718b8007f5
parentwww-servers/hinsightd: version bump v0.9.2 (diff)
downloadguru-d09ae1a3.tar.gz
guru-d09ae1a3.tar.bz2
guru-d09ae1a3.zip
app-emulation/arnold: new ebuild
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
-rw-r--r--app-emulation/arnold/Manifest1
-rw-r--r--app-emulation/arnold/arnold-20170513.ebuild51
-rw-r--r--app-emulation/arnold/files/arnold.pngbin0 -> 378 bytes
-rw-r--r--app-emulation/arnold/metadata.xml11
4 files changed, 63 insertions, 0 deletions
diff --git a/app-emulation/arnold/Manifest b/app-emulation/arnold/Manifest
new file mode 100644
index 000000000..108e37900
--- /dev/null
+++ b/app-emulation/arnold/Manifest
@@ -0,0 +1 @@
+DIST arnold-20170513.zip 17247943 BLAKE2B 53212fe2b517adb065b874c9b2c86a322429f87e22d563bb6cc63a48a37d4498aaaece6bee05a4509b7940a3b38af2f6c7fb40043a448ae56a15284079f010d8 SHA512 f1e56d7a887e459cc9679582ffebd230c7c86a971832a6030a12f5025c32a70338f3f6b3060c925321d0fd52759097a3ecb1801d2fbd75ceaa668e98184cc0ca
diff --git a/app-emulation/arnold/arnold-20170513.ebuild b/app-emulation/arnold/arnold-20170513.ebuild
new file mode 100644
index 000000000..ceda03f89
--- /dev/null
+++ b/app-emulation/arnold/arnold-20170513.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop wxwidgets
+
+DESCRIPTION="Amstrad CPC emulator"
+HOMEPAGE="http://www.cpctech.org.uk"
+SRC_URI="http://cpctech.cpc-live.com/arnsrc.zip -> ${P}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="inkz80"
+
+DEPEND="
+ media-libs/libsdl2
+ virtual/opengl
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/src
+
+WX_GTK_VER="3.0-gtk3"
+
+src_prepare() {
+ setup-wxwidgets
+ sed -i "4421s:=.*$:=wxT(\"/usr/share/${PN}/\");:" arngui/arnguiApp.cpp || die
+ # Prevent running at 150% of original speed
+ sed -i '390s/20000/30000/' arngui/sdl2/SDL2PlatformSpecific.cpp || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DCMAKE_SKIP_RPATH=YES
+ -DZ80_VERSION="USE_$(usex inkz80 INK ARN)Z80"
+ -DSDL_VERSION="USE_SDL2"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cd "${WORKDIR}"/exe/Gentoo/${PN} || die
+ doicon "${FILESDIR}"/${PN}.png
+ insinto /usr/share/${PN}/
+ dobin arnold
+ doins *.*
+}
diff --git a/app-emulation/arnold/files/arnold.png b/app-emulation/arnold/files/arnold.png
new file mode 100644
index 000000000..e54d0be93
--- /dev/null
+++ b/app-emulation/arnold/files/arnold.png
Binary files differ
diff --git a/app-emulation/arnold/metadata.xml b/app-emulation/arnold/metadata.xml
new file mode 100644
index 000000000..257786bed
--- /dev/null
+++ b/app-emulation/arnold/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <name>mazes-80</name>
+ <email>mazes-80@none.org</email>
+</maintainer>
+<use>
+ <flag name="inkz80">Use inkz80 processor emulation</flag>
+</use>
+</pkgmetadata>