aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-08-30 15:37:51 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-08-30 15:37:51 +0200
commitd0fdabcc7a3c99d49d9da01ae7fc695bddab6cf6 (patch)
treef5363916d098f60725c8e849ab62fd9711f397a2
parentnet-im/biboumi: Prevent implicit suid by fcaps. (diff)
downloadguru-d0fdabcc.tar.gz
guru-d0fdabcc.tar.bz2
guru-d0fdabcc.zip
net-im/biboumi: Remove old ebuilds.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
-rw-r--r--net-im/biboumi/Manifest2
-rw-r--r--net-im/biboumi/biboumi-8.5.ebuild88
-rw-r--r--net-im/biboumi/biboumi-9.0_rc1-r1.ebuild100
3 files changed, 0 insertions, 190 deletions
diff --git a/net-im/biboumi/Manifest b/net-im/biboumi/Manifest
index 1a361d5ba..34c6c222d 100644
--- a/net-im/biboumi/Manifest
+++ b/net-im/biboumi/Manifest
@@ -1,3 +1 @@
-DIST biboumi-8.5.tar.xz 142576 BLAKE2B 0e9284aa757f43a8436a7df5f78962663ca8cbf9b9a24dd5ea9c978e3240274b6f817b00169b478332f28b5f50a96833e10b7a3feec5e16b96638ec94daeb843 SHA512 36aa8c66a720faa8d9f0bd76fcd4ee382b7d21f6822de2a03582d03e8e7e440a4a08b1ff21e876e70e6b5b1012973c9936d85faecf4781a5d78e7d8b206c3ef6
-DIST biboumi-9.0-rc1.tar.xz 161008 BLAKE2B f1cf02d714a03633bcc8737d319f1c1c232b17edd6961ae9478189e85773b0cf28844e2d6173a63704353a371506cf1f4bc72a032434199e19d85a2383e9e261 SHA512 893d01e0b9d9606920b0cdecb45dec8a01b56701413d4633805db3dd5c32cd3bd2342c31d043beb34ac73c664dd968adc1f5e90a555369d8e6c78c4034bd1f20
DIST biboumi-9.0.tar.xz 161192 BLAKE2B 27c19f5c44e23caae07bd579b01d663e73cd8b432203ac95ae77e651936eea7cc443f389e589acebe5b36c32e96f215fdf0a86c97193726d601b53b709a2d66e SHA512 cfaacd831b56031906922472275c55fd6f1a5307ebe54959d21e3799ad4612499e8beeb34e8736df9eabc9fec1a861d17567250d64f316ace47395fd6c8f3c18
diff --git a/net-im/biboumi/biboumi-8.5.ebuild b/net-im/biboumi/biboumi-8.5.ebuild
deleted file mode 100644
index 23c875a9b..000000000
--- a/net-im/biboumi/biboumi-8.5.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake fcaps
-
-DESCRIPTION="XMPP gateway to IRC"
-HOMEPAGE="https://biboumi.louiz.org/"
-SRC_URI="https://git.louiz.org/biboumi/snapshot/biboumi-${PV}.tar.xz"
-
-LICENSE="ZLIB"
-SLOT="0/8"
-KEYWORDS="~amd64"
-IUSE="+idn logrotate postgres +sqlite +ssl systemd udns"
-
-DEPEND="
- dev-libs/expat
- virtual/libiconv
- sys-apps/util-linux
- sqlite? ( dev-db/sqlite )
- postgres? ( dev-db/postgresql:* )
- idn? ( net-dns/libidn )
- udns? ( net-libs/udns )
- ssl? ( dev-libs/botan:2 )
- !ssl? ( dev-libs/libgcrypt )
- systemd? ( sys-apps/systemd )
-"
-BDEPEND="app-text/pandoc"
-RDEPEND="
- ${DEPEND}
- acct-user/biboumi"
-
-DOCS=( README.rst CHANGELOG.rst )
-
-# Allow biboumi to run an identd on port 113.
-FILECAPS=( cap_net_bind_service+ep usr/bin/biboumi )
-
-src_prepare() {
- cmake_src_prepare
-
- if ! use systemd; then # Don't install biboumi.service.
- sed -i '/DESTINATION lib\/systemd\/system/d' CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_BOTAN="$(usex ssl)"
- -DWITH_LIBIDN="$(usex idn)"
- -DWITH_SYSTEMD="$(usex systemd)"
- -DWITH_UDNS="$(usex udns)"
- -DWITH_SQLITE3="$(usex sqlite)"
- -DWITH_POSTGRESQL="$(usex postgres)"
-
- -DWITHOUT_SYSTEMD="$(usex systemd no yes)"
- -DWITHOUT_POSTGRESQL="$(usex postgres no yes)"
- ) # The WITHOUT_* is really needed.
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if ! use systemd; then
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- fi
-
- if use logrotate; then
- insinto etc/logrotate.d
- if use systemd; then
- newins "${FILESDIR}/${PN}.logrotate.systemd" "${PN}"
- else
- newins "${FILESDIR}/${PN}.logrotate.openrc" "${PN}"
- fi
- fi
-
- diropts --owner=biboumi --group=biboumi --mode=750
- if use sqlite; then
- keepdir var/lib/biboumi
- fi
- keepdir var/log/biboumi
-
- insinto etc/biboumi
- insopts --group=biboumi --mode=640
- doins conf/biboumi.cfg
-}
diff --git a/net-im/biboumi/biboumi-9.0_rc1-r1.ebuild b/net-im/biboumi/biboumi-9.0_rc1-r1.ebuild
deleted file mode 100644
index 93f74515e..000000000
--- a/net-im/biboumi/biboumi-9.0_rc1-r1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake fcaps
-
-MY_PV="${PV/_/-}"
-
-DESCRIPTION="XMPP gateway to IRC"
-HOMEPAGE="https://biboumi.louiz.org/"
-SRC_URI="https://git.louiz.org/biboumi/snapshot/biboumi-${MY_PV}.tar.xz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+idn logrotate postgres +sqlite +ssl systemd udns"
-
-DEPEND="
- dev-libs/expat
- virtual/libiconv
- sys-apps/util-linux
- sqlite? ( dev-db/sqlite )
- postgres? ( dev-db/postgresql:* )
- idn? ( net-dns/libidn )
- udns? ( net-libs/udns )
- ssl? ( dev-libs/botan:2 )
- !ssl? ( dev-libs/libgcrypt )
- systemd? ( sys-apps/systemd )
-"
-BDEPEND="dev-python/sphinx"
-RDEPEND="
- ${DEPEND}
- acct-user/biboumi"
-
-PATCHES=( "${FILESDIR}/biboumi-9.0_rc1-split-cap-on-space.patch" )
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DOCS=( README.rst CHANGELOG.rst doc/user.rst )
-
-# Allow biboumi to run an identd on port 113.
-FILECAPS=( cap_net_bind_service+ep usr/bin/biboumi )
-
-src_prepare() {
- cmake_src_prepare
-
- if ! use systemd; then # Don't install biboumi.service.
- sed -i '/DESTINATION lib\/systemd\/system/d' CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_BOTAN="$(usex ssl)"
- -DWITH_LIBIDN="$(usex idn)"
- -DWITH_SYSTEMD="$(usex systemd)"
- -DWITH_UDNS="$(usex udns)"
- -DWITH_SQLITE3="$(usex sqlite)"
- -DWITH_POSTGRESQL="$(usex postgres)"
-
- -DWITHOUT_SYSTEMD="$(usex systemd no yes)"
- -DWITHOUT_POSTGRESQL="$(usex postgres no yes)"
- ) # The WITHOUT_* is really needed.
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- cmake_build man
-}
-
-src_install() {
- cmake_src_install
-
- if ! use systemd; then
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- fi
-
- if use logrotate; then
- insinto etc/logrotate.d
- if use systemd; then
- newins "${FILESDIR}/${PN}.logrotate.systemd" "${PN}"
- else
- newins "${FILESDIR}/${PN}.logrotate.openrc" "${PN}"
- fi
- fi
-
- diropts --owner=biboumi --group=biboumi --mode=750
- if use sqlite; then
- keepdir var/lib/biboumi
- fi
- keepdir var/log/biboumi
-
- insinto etc/biboumi
- insopts --group=biboumi --mode=640
- newins conf/biboumi.cfg biboumi.cfg.example
-}