aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-03 10:09:59 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-04 01:46:08 +0200
commitd13bcd7d0a21d9796891f96f0ec3666f8b2241f8 (patch)
tree58b0a04ae5aa7cdd8144c0a84464bfeb91ea0986
parentdev-ml/mirage-xen: initial import (diff)
downloadguru-d13bcd7d.tar.gz
guru-d13bcd7d.tar.bz2
guru-d13bcd7d.zip
dev-ml/xen-gnt: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-ml/xen-gnt/Manifest1
-rw-r--r--dev-ml/xen-gnt/metadata.xml11
-rw-r--r--dev-ml/xen-gnt/xen-gnt-4.0.0.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/xen-gnt/Manifest b/dev-ml/xen-gnt/Manifest
new file mode 100644
index 0000000000..c541047b7b
--- /dev/null
+++ b/dev-ml/xen-gnt/Manifest
@@ -0,0 +1 @@
+DIST xen-gnt-v4.0.0.tbz 11113 BLAKE2B fc96116ad592e5ba64169cbb56c9ff7837fbe512e74185b4b64aae5f37318c41ffa1944596e69c87352e0241de54717aea6ae65d02fe0929616b7be6bf9d2022 SHA512 add0a28fc21bde76cc84b2735efdff1dba1849a95e79cf5946eca9af9c1698a5cc68f0701459631b8eea15b0234942bbeb12e744fef6fccd84e29549303f57d0
diff --git a/dev-ml/xen-gnt/metadata.xml b/dev-ml/xen-gnt/metadata.xml
new file mode 100644
index 0000000000..e5f4c8ec96
--- /dev/null
+++ b/dev-ml/xen-gnt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-gnt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/xen-gnt/xen-gnt-4.0.0.ebuild b/dev-ml/xen-gnt/xen-gnt-4.0.0.ebuild
new file mode 100644
index 0000000000..843fe2e4cf
--- /dev/null
+++ b/dev-ml/xen-gnt/xen-gnt-4.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml bindings to the Xen grant tables libraries"
+HOMEPAGE="https://github.com/mirage/ocaml-gnt"
+SRC_URI="https://github.com/mirage/ocaml-gnt/releases/download/v${PV}/${PN}-v${PV}.tbz"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+DEPEND="
+ dev-ml/cstruct
+ dev-ml/cmdliner
+ <=dev-ml/io-page-2.2.0
+ dev-ml/lwt
+ dev-ml/lwt-dllist
+ dev-ml/mirage-profile
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune_src_install xen-gnt
+ dune_src_install xen-gnt-unix
+}