aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-03 11:51:43 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-03 12:37:11 +0500
commitd380582573c1ef57c582d019470e488f3f9ab712 (patch)
tree049501bae9553739b85f91e0be0bb5346508aaf3
parentdev-python/aspectlib: add 2.0.0 (diff)
downloadguru-d3805825.tar.gz
guru-d3805825.tar.bz2
guru-d3805825.zip
dev-python/hunter: add 3.5.1
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-python/hunter/Manifest1
-rw-r--r--dev-python/hunter/hunter-3.5.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/hunter/Manifest b/dev-python/hunter/Manifest
index 817554ec7..efb297676 100644
--- a/dev-python/hunter/Manifest
+++ b/dev-python/hunter/Manifest
@@ -1 +1,2 @@
DIST hunter-3.4.3.gh.tar.gz 538017 BLAKE2B 92ad2b653d0285059ea2f005c6ba9564f357e1ea438a0fe30087f88efa202aaa504bad65985a88484cf7178c24432ac44705098dabc2667328c71e0ee38f718c SHA512 921bb48ac5d384977908dda060e178e623eb7c1e4298cbf3c0a273cab23695f2a2a60221afb257e54cd144399d2b3b55b80ae9a2c7f71ba452894cc86112d5f7
+DIST hunter-3.5.1.gh.tar.gz 543137 BLAKE2B a06966f78fd442231c08e2aafe57702f7cc16e5db6aa9a1da7288e4a3a05ff9db3dfc49352641610ade31cb967996c3add64f07ddf637f46e5d269e9d0363a9f SHA512 2c302fa8b88c07be5361f11d8c250c5673be9dc691df9e966959eed45eaf0a8499ae8a6381256d83ab7219c818ed981628fb3299ef5d17d7b1d95c43a2fc63a7
diff --git a/dev-python/hunter/hunter-3.5.1.ebuild b/dev-python/hunter/hunter-3.5.1.ebuild
new file mode 100644
index 000000000..73d1df298
--- /dev/null
+++ b/dev-python/hunter/hunter-3.5.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Hunter is a flexible code tracing toolkit"
+HOMEPAGE="
+ https://github.com/ionelmc/python-hunter
+ https://pypi.org/project/hunter/
+"
+SRC_URI="https://github.com/ionelmc/python-${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/python-${P}"
+TEST_S="${S}_test"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.3.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aspectlib[${PYTHON_USEDEP}]
+ dev-python/ipdb[${PYTHON_USEDEP}]
+ dev-python/manhole[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-devel/gdb
+ )
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
+
+EPYTEST_DESELECT=(
+ tests/test_tracer.py::test_source_cython
+ tests/test_tracer.py::test_fullsource_cython
+
+ # too unstable
+ tests/test_remote.py
+)
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ ">=dev-python/sphinx-py3doc-enhanced-theme-2.3.2"
+
+src_unpack() {
+ default
+
+ cp -a "${S}" "${TEST_S}" || die
+ mv -f "${TEST_S}"/tests/setup.py "${TEST_S}"/setup.py || die
+}
+
+python_test() {
+ local TEST_ROOT="${BUILD_DIR}"/test
+ cp -a "${BUILD_DIR}/install" "${TEST_ROOT}" || die
+
+ cd "${TEST_S}" || die
+ distutils_pep517_install "${TEST_ROOT}"
+
+ local -x PATH="${TEST_ROOT}/usr/bin:${PATH}"
+ local -x PYTHONPATH="${S}/tests:${PYTHONPATH}"
+
+ cd "${T}" || die
+ epytest "${S}"/tests
+}