aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2022-01-17 04:36:23 +0100
committerAlexey Zapparov <alexey@zapparov.com>2022-01-17 04:36:23 +0100
commitd4a696225afffa1542beac38c620e28fcbfc90fe (patch)
treeb2eb7121b8c6a6e03b9eb91f721dd1cc3ae826f0
parentx11-drivers/OpenTabletDriver-bin: added v0.6.0.2, updated deps (diff)
downloadguru-d4a696225afffa1542beac38c620e28fcbfc90fe.tar.gz
guru-d4a696225afffa1542beac38c620e28fcbfc90fe.tar.bz2
guru-d4a696225afffa1542beac38c620e28fcbfc90fe.zip
x11-themes/bibata-xcursors: fix QA failures
Closes: https://bugs.gentoo.org/830149 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
-rw-r--r--x11-themes/bibata-xcursors/bibata-xcursors-1.1.2-r1.ebuild (renamed from x11-themes/bibata-xcursors/bibata-xcursors-1.1.2.ebuild)17
1 files changed, 16 insertions, 1 deletions
diff --git a/x11-themes/bibata-xcursors/bibata-xcursors-1.1.2.ebuild b/x11-themes/bibata-xcursors/bibata-xcursors-1.1.2-r1.ebuild
index 170981fd1..7797f0381 100644
--- a/x11-themes/bibata-xcursors/bibata-xcursors-1.1.2.ebuild
+++ b/x11-themes/bibata-xcursors/bibata-xcursors-1.1.2-r1.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1
+
MY_PN="Bibata_Cursor"
DESCRIPTION="Opensource, compact, and material-designed cursor set"
@@ -18,12 +21,24 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="x11-libs/libXcursor"
BDEPEND="
- dev-python/clickgen
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/clickgen[${PYTHON_USEDEP}]
+ ')
app-arch/unzip
"
S="${WORKDIR}/${MY_PN}-${PV}"
+python_check_deps() {
+ has_version -b "dev-python/clickgen[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
src_unpack() {
unpack "${P}.tar.gz"
cd "${S}" || die "Cannot change dir into '${S}'"