aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-02-27 13:05:05 +0100
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-02-27 13:05:44 +0100
commitd76526be2acf0fa9a8e7519344e542ee393d2a51 (patch)
treed6ff96dadf25778c88d7c1ab7c7f687dd1237512
parentmedia-sound/spotify-adblock: add QA_FLAGS_IGNORED (diff)
downloadguru-d76526be2acf0fa9a8e7519344e542ee393d2a51.tar.gz
guru-d76526be2acf0fa9a8e7519344e542ee393d2a51.tar.bz2
guru-d76526be2acf0fa9a8e7519344e542ee393d2a51.zip
net-misc/tinyssh: version bump, 20220222
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
-rw-r--r--net-misc/tinyssh/Manifest1
-rw-r--r--net-misc/tinyssh/tinyssh-20220222.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/tinyssh/Manifest b/net-misc/tinyssh/Manifest
index eb7da3e1f..68aaf0e1a 100644
--- a/net-misc/tinyssh/Manifest
+++ b/net-misc/tinyssh/Manifest
@@ -1 +1,2 @@
DIST tinyssh-20210601.tar.gz 248047 BLAKE2B e661ee41443fec2474a7e0b8d2291a8c81e4852ac1cb51599de2ba748fe7fba9c81478fe616f6878e8e16577dd3a1e3c748613c47627c04733e3f42015297260 SHA512 e49397fc6edce093d9a5697f3a21f18cf9999bb257e532c0548e9a12be28eab09bf319bdf0fef0606831e826fd6845f604347e5bc1c089f0904eb4e5ab46c339
+DIST tinyssh-20220222.tar.gz 248788 BLAKE2B cabcd12d3cd6d862fea9c4cba03b72ed2edebe2584feb5cdcff9294b05f41e553fb1f9f127306a63890bc6481eb88b04953f357cf9c505e4678f85f7a38128c9 SHA512 ff6285abd5a963a031cb21fbfdd8fe38e7d7a4d17b053ebc2abeb503fdd2afb5d3a3c0921ea53624ae3d8c29cd64a7fa6810e2c053aaf4d2ad949d7c4ba21ad0
diff --git a/net-misc/tinyssh/tinyssh-20220222.ebuild b/net-misc/tinyssh/tinyssh-20220222.ebuild
new file mode 100644
index 000000000..df6be2ec4
--- /dev/null
+++ b/net-misc/tinyssh/tinyssh-20220222.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A small SSH server with state-of-the-art cryptography"
+HOMEPAGE="https://tinyssh.org"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/janmojzis/tinyssh.git"
+else
+ SRC_URI="https://github.com/janmojzis/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+
+IUSE="+sodium"
+
+DEPEND="
+ sodium? ( dev-libs/libsodium )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/ucspi-tcp
+"
+
+src_prepare() {
+ # Leave optimization level to user CFLAGS
+ sed -i 's/-Os -fomit-frame-pointer -funroll-loops//g' ./conf-cc || die
+
+ # Use make-tinysshcc.sh script, which has no tests and doesn't execute
+ # binaries. See https://github.com/janmojzis/tinyssh/issues/2
+ sed -i 's/make-tinyssh\.sh/make-tinysshcc.sh/g' ./Makefile || die
+
+ default
+}
+
+src_compile() {
+ if use sodium
+ then
+ emake \
+ CC="$(tc-getCC)"
+ LIBS="-lsodium" \
+ CFLAGS="${CFLAGS} -I/usr/include/sodium" \
+ LDFLAGS="${LDFLAGS} -L/usr/lib"
+ else
+ emake CC="$(tc-getCC)"
+ fi
+}
+
+src_install() {
+ dosbin build/bin/tinysshd{,-makekey}
+ dobin build/bin/tinysshd-printkey
+ doman man/*
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ systemd_newunit "${FILESDIR}/${PN}.service" "${PN}@.service"
+ systemd_newunit "${FILESDIR}/${PN}.socket" "${PN}@.socket"
+ systemd_dounit "${FILESDIR}/${PN}-makekey.service"
+}
+
+pkg_postinst() {
+ einfo "TinySSH is in beta stage, and ready for production use."
+ einfo "See https://tinyssh.org for more information."
+}