aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber@sysrq.in>2021-05-16 18:46:54 +0500
committerAnna Vyalkova <cyber@sysrq.in>2021-05-16 19:05:03 +0500
commitd89786cb1d45ea18df86e694c44dda76b5c67033 (patch)
tree2a05c89ac7556ba8aced754a63e575d8ea670892
parentsci-libs/meschach: fix CC (diff)
downloadguru-d89786cb.tar.gz
guru-d89786cb.tar.bz2
guru-d89786cb.zip
sci-mathematics/chaco: fix CC
Closes: https://bugs.gentoo.org/785166 Signed-off-by: Anna Vyalkova <cyber@sysrq.in>
-rw-r--r--sci-mathematics/chaco/chaco-2.2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sci-mathematics/chaco/chaco-2.2.ebuild b/sci-mathematics/chaco/chaco-2.2.ebuild
index 745dd01c6..f7d0a7d15 100644
--- a/sci-mathematics/chaco/chaco-2.2.ebuild
+++ b/sci-mathematics/chaco/chaco-2.2.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Software for Partitioning Graphs"
HOMEPAGE="https://www3.cs.stonybrook.edu/~algorith/implement/chaco/implement.shtml"
@@ -13,10 +15,13 @@ KEYWORDS="~amd64 ~x86"
PATCHES=( "${FILESDIR}/makefile.patch" )
S="${WORKDIR}/Chaco-${PV}"
+src_compile() {
+ cd code || die
+ tc-export CC
+ default
+}
+
src_install() {
- pushd code || die
- emake
- popd || die
dobin "exec/chaco"
dodoc -r doc/.
}